Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84367 - application bug: nsupdate has SIGCHLD set to SIG_IGN but calls wait4.
Summary: application bug: nsupdate has SIGCHLD set to SIG_IGN but calls wait4.
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bind
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 23:27 UTC by Aleksey Nogin
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:49 UTC


Attachments (Terms of Use)

Description Aleksey Nogin 2003-02-14 23:27:14 UTC
bind-utils-9.2.1-16
kernel-2.4.20-2.47.1
rawhide-release-20030213-1

dmesg shows:

application bug: nsupdate(1151) has SIGCHLD set to SIG_IGN but calls wait4.

Comment 1 Bill Nottingham 2003-02-17 21:24:15 UTC
When was this called?

Comment 2 Bill Nottingham 2003-02-17 21:25:17 UTC
(This may be a dup of 84184.)

Comment 3 Daniel Walsh 2003-02-17 21:55:27 UTC
There is no SIGCHLD (set to SIG_IGN) call within the bind tree.

Dan

Comment 4 Aleksey Nogin 2003-02-18 21:38:14 UTC
It's called from /sbin/ifup-local on PCMCIA wireless card. So indeed could be a
dup of bug 84184.

Comment 5 Daniel Walsh 2003-03-04 18:22:36 UTC

*** This bug has been marked as a duplicate of 84184 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:51:49 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.