Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84350 - 2.4.18-24 probes USB before SCSI making CF reader be /dev/sda instead of first drive on SCSI controller as expected.
Summary: 2.4.18-24 probes USB before SCSI making CF reader be /dev/sda instead of firs...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 8.0
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 19:23 UTC by Walter B Kulecz, PhD
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-18 17:36:09 UTC


Attachments (Terms of Use)

Description Walter B Kulecz, PhD 2003-02-14 19:23:18 UTC
Description of problem:
updated kernel 2.4.18-24.i686 probes USB before SCSI assigning /dev/sda to
attached compact flash reader instead of device on SCSI controller.

Version-Release number of selected component (if applicable):


How reproducible:
every boot.
fixed by booting 2.4.18-18.8.0.i686 instead


Steps to Reproduce:
1.install all updates
2.add USB compact flash reader on SCSI system
3. update to kernel 2.4.18-24.8.0.i686
    
Actual results:
no swap since real scsi device becomes sdb and partiton sda2 doesn't exist
would be panic if / not mounted by label

Expected results:
normal bootup with first drive on first SCSI controller as sda

Additional info:

Comment 1 Arjan van de Ven 2003-02-15 10:35:04 UTC
this order is determined by mkinitrd not the kernel

Comment 2 Jeremy Katz 2003-02-18 17:36:09 UTC
This is fixed in newer versions of mkinitrd


Note You need to log in before you can comment on or make changes to this bug.