Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84342 - gnome-terminal spews warnings
Summary: gnome-terminal spews warnings
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libgnomeui
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-14 17:58 UTC by Chris Ricker
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-17 21:35:09 UTC


Attachments (Terms of Use)

Description Chris Ricker 2003-02-14 17:58:35 UTC
[cricker@winsucks cricker]$ gnome-terminal 

(gnome-terminal:27344): GnomeUI-WARNING **: gnome_icon_entry_gnome_entry
deprecated, use changed signal!

(gnome-terminal:27344): GnomeUI-WARNING **: gnome_icon_entry_gnome_entry
deprecated, use changed signal!


This is with gnome-terminal-2.2.0-2 on a pre-beta5 system

Comment 1 Havoc Pennington 2003-02-18 19:54:03 UTC
The bug here is in libgnomeui/glade/glade-gnome.c

Comment 2 Elliot Lee 2003-02-21 20:41:52 UTC
So glade-gnome.c is using deprecated routines because the person who deprecated
the routines hadn't thought some of the side effects through. They wrote "this
is deprecated in favour of the above" (gnome-icon-entry.h) to indicate that
people should use the gnome_icon_entry_* routines instead of retrieving the
GnomeEntry and calling the gnome_entry on it. The problem is that there is no
gnome_icon_entry_ do what glade-gnome.c wants to do.

Either glade-gnome.c needs to be fixed to not export the features of
GnomeIconEntry that require accessing the contained GnomeEntry, or
gnome-icon-entry needs to provide wrappers for all the GnomeEntry features, or
gnome-icon-entry needs to stop spewing warnings (and be made non-deprecated).
The latter is the least intrusive.

Comment 3 Havoc Pennington 2003-02-21 20:45:47 UTC
My preferred fix for this release would be to just remove the warning.

Comment 4 Chris Ricker 2003-10-17 21:35:09 UTC
I don't see this in severn


Note You need to log in before you can comment on or make changes to this bug.