Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84330 - nsswitch fails when querying groups from winbindd (Samba component)
Summary: nsswitch fails when querying groups from winbindd (Samba component)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 15:59 UTC by David Boynton
Modified: 2016-11-24 14:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-27 16:56:26 UTC


Attachments (Terms of Use)

Description David Boynton 2003-02-14 15:59:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When querying domain groups for a user via nsswitch/winbindd the buffer passed
to libnss_winbind is too small (about 1k).
libnss_winbind returns NSS_TRYAGAIN and sets errno=ERANGE.
As far as I can tell, glibc never "trys again" it just fails, so all calls to
getgrgid fail for groups that have a lot of members.

I have only tested this using winbind, it is the only nss component I have
installed that will return large numbers of users/groups.

As a result, users cannot authenticate to my Samba server when it's set for
domain security.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure samba with "security = domain" and to use winbind
2.Add winbind to passwd and group lines of /etc/nsswitch.conf
3.Issue "groups <domain user>" at the command prompt.
    

Actual Results:  (long pause)
id: cannot find name for group ID 10001 (or some other number in winbind's range)


Expected Results:  List of domain groups the user belongs to

Additional info:

Works fine in RedHat 7.3

Comment 1 Jakub Jelinek 2003-02-18 13:09:31 UTC
Can you please try rawhide glibc (like 2.3.1-46)?

Comment 2 David Boynton 2003-02-18 18:12:57 UTC
Installing rawhide glibc-2.3.1-46 has fixed the problem.

Comment 3 David Boynton 2003-02-20 15:14:29 UTC
Well, installing RawHide fixed the Samba problem, but broke several other
programs, including rpm. :(


Comment 4 Ulrich Drepper 2004-09-27 16:56:26 UTC
Since the problem is fixed, I close the bug.


Note You need to log in before you can comment on or make changes to this bug.