Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84315 - up2date does not respond to the --nox option
Summary: up2date does not respond to the --nox option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 7.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 11:12 UTC by Salim Fadhley
Modified: 2007-04-18 16:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-14 16:57:34 UTC


Attachments (Terms of Use)

Description Salim Fadhley 2003-02-14 11:12:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

Description of problem:
According to the man-page the --nox option should cause up2date not to attempt
to launch a graphical interface. Using this option should mean that up2date does
not need a valid DISPLAY. 

[root@chalfont dan_chambers]# up2date --nox
The application 'up2date' lost its connection to the display localhost:10.0;
most likely the X server was shut down or you killed/destroyed
the application.

[root@chalfont dan_chambers]#

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take PUTTY (a windows SSH client) and enable X tunneling.
2. SSH into a Redhat box from a windows machine that is not running X.
3. Try to start up2date in text only mode with the --nox option.
4. Get angry because you have to clear out the DISPLAY environment variable to
make it work in text mode.
    

Actual Results:  up2date complains that it cannot find an X-server

Expected Results:  Normal up2date operation... in this case grabing some RH fixes.

Additional info:

Comment 1 Adrian Likins 2003-02-14 16:57:34 UTC
run /usr/sbin/up2date as root instead. What your seeing is userhelper (the
dialog that asks you for a root password) attempting to run in
X. up2date itself respects --nox, the userhelper dialog does not.
This has been fixed in later releases.

>1. Take PUTTY (a windows SSH client) and enable X tunneling.
>2. SSH into a Redhat box from a windows machine that is not running X.

Thats somewhat of a broken case. up2date itself knows how to 
handle this case (even sans --nox). It will attempt to talk to
the bogus DISPLAY, and when that fails, fall back to nox mode. 

userhelper, on the other hand, does not. This is fixed in 8.0.
so closing as "currentrelease"


Note You need to log in before you can comment on or make changes to this bug.