Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84311 - Excludepath on rpm 4.2, rawhide
Summary: Excludepath on rpm 4.2, rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 09:57 UTC by Ivan Gyurdiev
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-27 19:48:52 UTC


Attachments (Terms of Use)
Fix/workaround for --excludepath (deleted)
2003-07-19 15:11 UTC, Konstantin Bukharov
no flags Details | Diff

Description Ivan Gyurdiev 2003-02-14 09:57:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
Similar problems have been marked as CLOSED and DUPLICATE
for earlier versions of rpm, but excludepath still doesn't work on 4.2. Here's a
demo with SysVinit on a devfs enabled system.

[root@cobra archives]# rpm -Uvh --excludepath /dev Sys*
warning: SysVinit_2.84-13_i386.rpm: V3 DSA signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:SysVinit               ########################################### [100%]
error: unpacking of archive failed on file /dev/initctl: cpio: rename failed -
Operation not permitted
[root@cobra archives]# rpm -q rpm
rpm-4.2-0.66
[root@cobra archives]# 

Note: your bugzilla database marks the version of rpm incorrectly as 1.0. That's
the only version available to select.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh --excludepath 
2.
3.
    

Additional info:

Comment 1 Konstantin Bukharov 2003-07-19 15:11:12 UTC
Created attachment 93018 [details]
Fix/workaround for --excludepath

Actually this bug exists in RedHat Linux 9 also (not only in rawhide).

Problem is in fact, that --excludepath option is processed in rpmfi.c around
line 788 (function relocateFileList called from rpmfiNew). But FA_SKIPNSTATE
flags added in relocateFileList due to '--excludepath' option are discarded in
transaction.c around line 1528 in function rpmtsRun. Note that at this place,
old fi->actions saved at line 1512 contains only FA_SKIPNSTATE due to
--excludedocs/--excludeconf.
As quick workaround to restore --excludepath functionality it is needed to copy
FA_SKIPNSTATE flags from fi-actions to actions before freeing fi-actions at
line 1528.

Comment 2 Jeff Johnson 2003-12-27 19:48:52 UTC
This is fixed in (at least) rpm-4.2.2. Your analysis was mostly
correct, but the real problem was elsewhere.


Note You need to log in before you can comment on or make changes to this bug.