Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84304 - Unable to compile kernel from kernel-source-2.4.18-24.8.0
Summary: Unable to compile kernel from kernel-source-2.4.18-24.8.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 07:35 UTC by Matt Swanson
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-08 02:11:41 UTC


Attachments (Terms of Use)

Description Matt Swanson 2003-02-14 07:35:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If more detail is required please let me know - I have my .config file available
and can specifically replicate the errors -- If you make mrproper, copy a
default config file from configs (i686 uniprocessor in my case) to the top level
directory and make oldconfig dep clean bzImage modules -- the compilation will
die at various points in the modules phase. I have removed all the offending
items but now my vmware modules will not compile against the new kernel I have
built - a problem with the bridge.c file, line 653 too many parameters. This is
a common error I found during the compile problems -- too many parameters and
then a fatal error.I do not understand how the kernel could have been built
against these sources as a default build fails. Problems specifically with the
ieee1394 modules, gigabit network modules, AFS filesystem - all enabled by
default. The only mitigating factor is that I have commented out my
"extraversion" info in my top level Makefile and changed the patch to 1824 -
this is required as the ng-wlan drivers will not compile against a RH kernel
with extraversioning enabled. I have no problems with kernel-2.4.18-19.8.0, it
all works great. Problem has only arisen since 2.4.18-24 was released.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Follow RedHats instructions on compiling a custom kernel - use make oldconfig
or make menuconfig - problem still occurs.
2.
3.
    

Actual Results:  make modules failed.

Expected Results:  make modules should have worked and a working kernel should
have resulted.

Additional info:

See bug description

Comment 1 max 2003-03-05 11:45:04 UTC
Had same problems, solved them by issuing 
make clean
make mrproper

then loading a default configuration in configs/
I just compiled again after editing the configuration, still have to check the
kernel, but beware that 

make install 

fails at some point and you have to make a dir to install the kernel (other bug
submitted).


Note You need to log in before you can comment on or make changes to this bug.