Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84303 - redhat-config-packages does not function properly
Summary: redhat-config-packages does not function properly
Keywords:
Status: CLOSED DUPLICATE of bug 74877
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 07:30 UTC by David Archer
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:47 UTC


Attachments (Terms of Use)

Description David Archer 2003-02-14 07:30:55 UTC
Description of problem:

When I run redhat-config-packages, a dialog box appears with a progress bar, it
finishes, then program stops. When run from a terminal the following appears:

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in __init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in readCompsFile

    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in
setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence




Version-Release number of selected component (if applicable):


How reproducible:

Every time it runs, either from command line or from icon in KDE.

Steps to Reproduce:
1. Run redhat-config-packages
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Jeremy Katz 2003-02-14 14:17:38 UTC

*** This bug has been marked as a duplicate of 74877 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.