Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84290 - apache-manual is missing mod_alias.html
Summary: apache-manual is missing mod_alias.html
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 7.3
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 03:16 UTC by Carl Litt
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-21 10:41:21 UTC


Attachments (Terms of Use)
patch to fix problem twice (deleted)
2003-02-16 03:07 UTC, Bishop Clark
no flags Details | Diff

Description Carl Litt 2003-02-14 03:16:52 UTC
Description of problem:
Documentation file mod_alias.html is missing

Version-Release number of selected component (if applicable):
apache-manual-1.3.27-2

How reproducible:
Try to find it

Steps to Reproduce:
1. Install apache-manual-1.3.27-2
2. Open /var/www/html/manual/mod/index.html in a browser
3. Click on the link for mod_alias
    
Actual results:
mod_alias.html is missing

Expected results:
Duh :)

Additional info:
mod_alias.html is still part of the Apache distribution.

Comment 1 Bishop Clark 2003-02-16 03:07:31 UTC
Created attachment 90113 [details]
patch to fix problem twice

This is a simple enough bug - the dist doesn't seem to include a mod_alias.html
file in addition to the mod_alias.html.en file, and the RPM build doesn't
include any .html.<lang> files;  just .html files.

So, the fix can have two forms:
 - include all the translated html files
 - copy the .html.en file as .html as well

The patch I'm attaching does both.  Pick one solution you like, and go with it.

Comment 2 Joe Orton 2004-09-21 10:41:21 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.



Note You need to log in before you can comment on or make changes to this bug.