Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84268 - MakeMaker not making good Makefiles
Summary: MakeMaker not making good Makefiles
Keywords:
Status: CLOSED DUPLICATE of bug 87682
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
: 88341 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-13 20:33 UTC by Zach Gelnett
Modified: 2007-04-18 16:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:47 UTC


Attachments (Terms of Use)

Description Zach Gelnett 2003-02-13 20:33:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; U)

Description of problem:
Here is a snippit from the Makefile created with the command "perl Makefile.PL" for the Digest::MD5 package (notice the messed up 
lines, some cut off, some with single ticks and such):

# --- MakeMaker constants section:
AR_STATIC_ARGS = cr
NAME = Digest::MD5
DISTNAME = Digest-MD5
NAME_SYM = Digest_MD5
VERSION = 2.23
VERSION_SYM = 2_23
XS_VERSION = 2.23
INST_ARCHLIB = blib/arch
INST_SCRIPT = blib/script
INST_BIN = blib/bin
INST_LIB = blib/lib
INSTALLDIRS = perl
PREFIX = /usr
SITEPREFIX = /usr
VENDORPREFIX = /usr
INSTALLPRIVLIB = /usr/lib/perl5/5.8.0
INSTALLSITELIB = /usr/lib/perl5/site_perl/5.8.0'
installsiteman1='/usr/share/man/man1'
installsiteman3='/usr/share/man/man3'
installsitescript='/usr/bin'
installstyle='lib/perl5'
installusrbinperl='define'
installvendorarch='/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi'
installvendorbin='/usr/bin'
installvendorhtml1=''
installvendorhtml3=''
installvendorlib='/usr/lib/perl5/vendor_perl/5.8.
INSTALLVENDORLIB = ib/perl5'
installusrbinperl='def
INSTALLARCHLIB = /usr/lib/perl5/5.8.0/i386-linux-thread-multi
INSTALLSITEARCH = /usr/lib/pe
INSTALLVENDORARCH = /usr/lib/perl5/v
INSTALLBIN = /usr/bin'
installhtml1dir=''
installhtml3dir=''
installman1
INSTALLSITEBIN = /usr
INSTALLVENDORBIN = /usr/bin'
installvendorhtml1=''
installvendorhtml3=''
installvendorlib='/us
INSTALLSCRIPT = /usr/bin
PERL_LIB = /usr/lib/perl5/5.8.0
PERL_ARCHLIB = /usr/lib/perl5/5.8.0/i386-linux-thread-multi
VENDORLIBEXP = ib/perl5'
installusrbinperl='def
SITELIBEXP = '/usr/lib/perl5/site_perl'
sit
SITEARCHEXP = /usr/lib/pe
VENDORARCHEXP = /usr/lib/perl5/v
LIBPERL_A = libperl.a'
libc='
FIRST_MAKEFILE = Makefile
MAKE_APERL_FILE = Makefile.aperl
PERLMAINCC = $(CC)
PERL_INC = /usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE
PERL = /usr/bin/perl
FULLPERL = /usr/bin/perl
PERLRUN = $(PERL)
FULLPERLRUN = $(FULLPERL)
PERLRUNINST = $(PERLRUN) "-I$(INST_ARCHLIB)" "-I$(INST_LIB)"
FULLPERLRUNINST = $(FULLPERLRUN) "-I$(INST_ARCHLIB)" "-I$(INST_LIB)"
ABSPERL = $(PERL)
ABSPERLRUN = $(ABSPERL)
ABSPERLRUNINST = $(ABSPERLRUN) "-I$(INST_ARCHLIB)" "-I$(INST_LIB)"
FULL_AR = /usr/bin/ar
PERL_CORE = 0
NOOP = $(SHELL) -c true
NOECHO = @

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Redhat 8.0.93
2. Get all up2date updates
3. Run perl -MCPAN -e 'install Digest::MD5'
    

Additional info

Comment 1 Zach Gelnett 2003-02-24 14:35:36 UTC
I've updated to Phoebe 8.0.94 and the bug persists.  Is there anything i can 
provide to help with solving this issue?  I'm getting strange errors with 
logwatch and awstats also, both items that use perl.  The logwatch problem is 
that I receive 1 email detailing the logwatch report, and a second about how it 
failed mailing emails to Logwatch@host  for@host and host@host.  The awstats is 
that the page created by perl has all sorts of errors at the top.  Any ideas?

Comment 2 Wade Minter 2003-03-01 02:10:12 UTC
I'll verify that I see this same problem.

Comment 3 Zach Gelnett 2003-03-01 02:15:49 UTC
Ok, I've found a way to get around this:  Use the perl module in webmin to 
install the cpan stuff.  Now, i dont know why webmin install works and the 
standard install doesnt but this does get around it (altho i do prefer command 
line).

Comment 4 Zach Gelnett 2003-04-03 14:54:46 UTC
I continue to get this error in RH 9.  Any ideas?

Comment 5 Zach Gelnett 2003-04-04 03:06:28 UTC
Clear out the LANG variable and it will fix the issue.

Comment 6 John Simpson 2003-04-09 05:51:46 UTC
*** Bug 88341 has been marked as a duplicate of this bug. ***

Comment 7 Wade Minter 2003-04-24 18:45:56 UTC

*** This bug has been marked as a duplicate of 87682 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:51:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.