Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84256 - [lvm] RuntimeError: Checking the size of a partition which hasn't been allocated yet
Summary: [lvm] RuntimeError: Checking the size of a partition which hasn't been alloca...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-13 19:30 UTC by Mike McLean
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-05 03:05:16 UTC


Attachments (Terms of Use)

Description Mike McLean 2003-02-13 19:30:08 UTC
* -re0212
* cd gui install

In disk druid,
(1) clear all partitions
(2) create /boot 
(3) make two raid partitions
(4) make a raid1 device, format as LVM
(5) edit free space and format as LVM


Traceback (most recent call last):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1030, in editCb
    self.editPartitionRequest(request, isNew = 1)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1087, in editPartitionRequest
    if self.refresh():
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1013, in refresh
    self.populate()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 788, in populate
    self.tree[iter]['Size (MB)'] = "%g" %
(request.getActualSize(self.partitions, self.diskset),)
  File "/usr/lib/anaconda/partRequests.py", line 604, in getActualSize
    partsize = req.getActualSize(partitions, diskset)
  File "/usr/lib/anaconda/partRequests.py", line 439, in getActualSize
    raise RuntimeError, "Checking the size of a partition which hasn't been
allocated yet"
RuntimeError: Checking the size of a partition which hasn't been allocated yet

Comment 2 Michael Fulbright 2003-02-14 16:13:22 UTC
Wasnt there also part of this that required the last partition being created to
fail to be allocated due to the wierd cylinder roundoff error?

Comment 3 Mike McLean 2003-02-14 16:21:51 UTC
Probably, but I was getting that error by simply editing free space into a
partition.

It was only when I first set up lvm-on-raid and then edited free space into an
LVM partition that I got the traceback to follow the "cylinder boundary" error
dialog.

Comment 4 Michael Fulbright 2003-05-05 16:13:38 UTC
This is something I cannot reliable reproduce. If you have a particular
machine/hard drive combination that will do this I can take a look.

BTW the LVM and RAID stuff are a red herring as far as I can tell. Its more
related to something in parted that gets confused about partition offsets and
tells us there is a range of cylinders free and yet if you ask for that range it
reports a problem.

Comment 5 Jeremy Katz 2004-10-05 03:05:16 UTC
Closing until we get a reliable reproducer.


Note You need to log in before you can comment on or make changes to this bug.