Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84247 - XKeepsFailing depends on gettext
Summary: XKeepsFailing depends on gettext
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-13 19:04 UTC by Miloslav Trmac
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-04 11:41:42 UTC


Attachments (Terms of Use)

Description Miloslav Trmac 2003-02-13 19:04:30 UTC
Steps to Reproduce:
0.rpm -e gettext
1.Be an total idiot
2.Set your mouse type to "sun"
3.Try to start X again
    
Description of problem:
After a few attempts, XKeepsFailing kicks in. It doesn't
run redhat-config-xfree86, although it seems to be supposed to.
Anyway, then it displays a dialog (using gdialog), that is completely
empty (1) except for something unreadable at the bottom, which is
probably supposed to be a button. (2)
I can navigate through a few dialogs, but I don't see any text
and the buttons are unreadable.

1) Looking at the script, it invokes 'gettext -s', but gdm doesn't
require gettext. The scripts seems to attempt to avoid bash-isms,
but here a bashism would be useful the $" " way of getting
translations. Anyway, the current version attempts to run gettext
and gets empty strings in return.

So either gettext should be required, or the script needs fixing.

2) runnig gdialog when logged in in text mode produces correctly
looking buttons though.
A theory (not checked at all), is that when nobody is logged in
on a VT, it is in a "default" state which doesn't have UTF-8
support enabled, the support is enabled after logging in.
This can be verified by setting your keyboard via e.g.
loadkeys -u cz-lat2.
Then you should be able to produce &ecaron, &scaron, &ccaron by
pressing AltGr-{2,3,4} when logged in a VT. When not logged in,
these keys produce UTF-8 garbage.
So, possibly the dialogs are run on a VT that has UTF-8 disabled.

Version-Release number of selected component (if applicable):
gdm-2.4.1.1-1

Comment 1 Philip Long 2003-02-17 17:08:27 UTC
After changing screens from a CRT (1280x1024) to an SGI 1600SW (1600x1024)
(hooray for ebay) I got something simialr - 

the gdm screen was blank,  but the mouse pointer was there.  I didn't see any
garbage at the bottom, though.

I changed resoultions to 800x600 and progressed bac to 1600x1024 and the problem
seem to have resolved itself.

Comment 2 Miloslav Trmac 2003-02-17 17:32:20 UTC
Philip: if you saw a (graphic) mouse pointer and nothing more, it is
a different problem.
I was talking about an empty dialog, i.e. a cyan rectangle with some
"garbage buttons" at the bottom. And in text mode.

Comment 3 Havoc Pennington 2003-02-18 19:36:22 UTC
Probably some UTF-8 mess

Comment 4 Miloslav Trmac 2003-08-07 21:24:20 UTC
In severn, the dialogs are quite readable. None of dialog, gdialog and whiptail
are able to display perfect dialog windows in UTF-8, but that's for separate
bug reports.

Still unfixed is the missing dependency of gdm on /bin/gettext.

Comment 5 George Lebl 2003-08-07 22:09:10 UTC
In upstream 2.4.1.5 the dependency is fixed by just not using gettext if it
isn't found.  In the devel version I have a separate utility to do translations
rather then rely on gettext.  This can be fixed in older versions by just taking
the XKeepsFailing script from the 2.4.1.5 version.

Comment 6 Alexander Larsson 2003-09-04 11:41:42 UTC
We upgraded to the gnome 2.4 gdm, so I assume (since george said so) that this
is fixed now.



Note You need to log in before you can comment on or make changes to this bug.