Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84219 - Kickstart installation fail. RH 8.0
Summary: Kickstart installation fail. RH 8.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
: 87738 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-13 16:58 UTC by CelsoSuzuki
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-13 20:46:37 UTC


Attachments (Terms of Use)

Description CelsoSuzuki 2003-02-13 16:58:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I'm trying to do a installation with kickstart and I got the error message:
Exception Occurred
An unhandled exception has occurred. This is most likely a bug. Please copy the
full text of this exception or save the crash dump to a floppy the file a
detailed bug report against anaconda at http://bugzilla.redhat.com/bugzilla
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 402, in run
    (step, args) = dispatch.currentStep()
  File "/usr/lib/anaconda/dispatch.py", line 251, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 121, in readPackages
    id.instClass.setGroupSelection(id.comps)
  File "/usr/lib/anaconda/kickstart.py", line 1119, in setGroupSelection
    comps[n].select()
  File "/usr/lib/anaconda/comps.py", line 580, in __getitem__
    return self.compsDict[key]
KeyError: Minimal

There are more things at the anacdump.txt file but I don't think that is important.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a kickstart file with the Kickstart Configurator
2. Create a boot disk with the bootnet.img
3. Change the syslinux.cfg with
default ks
prompt 0
timeout 600
label ks
  kernel vmlinuz
  append ks=floppy initrd=initrd.img lang= devfs=nomount ramdisk_size=9216

And copy the ks.cfg to the diskette.
The ks.cfg file is:
#Generated by Kickstart Configurator

#System language
lang en_US

#Language modules to install
langsupport en_US

#System keyboard
keyboard us

#System mouse
mouse none

#System timezone
timezone --utc America/Sao_Paulo

#Root password
rootpw --iscrypted $1$Z2O/8KDi$nkej1sP3on6EI5AmCCiht/

#Reboot after installation
reboot

#Use text mode install
text

#Install Red Hat Linux instead of upgrade
install

#Use NFS installation media
nfs --server 192.168.160.10 --dir /home/linux/rh80

#System bootloader configuration
bootloader --useLilo --linear --location=mbr

#Clear the Master Boot Record
zerombr yes

#Clear all partitions from the disk
clearpart --all --initlabel

#Disk partitioning information
part /boot --fstype ext3 --size 100
part / --fstype ext3 --size 2500
part swap --size 1000
part /home --fstype ext3 --size 1 --grow

#Use static networking
network --bootproto static  --ip 192.168.162.16  --netmask 255.255.240.0 
--gateway 192.168.160.122  --nameserver 192.168.160.17

#System authorization information
auth  --useshadow  --enablemd5

#Firewall configuration
firewall --disabled

#Do not configure the X Window System
skipx

%packages --resolvedeps
@Minimal


    

Actual Results:  I got the exception error

Expected Results:  Linux installed at the machine

Additional info:

The machine is a Pentium 2GHz, with 256MRam and 20GHD

Comment 1 CelsoSuzuki 2003-02-13 18:50:49 UTC
Hi,

I tried to install everything
%packages --resolvedeps
# @Minimal
@Everything

And it installs ok!
So the problem is with the comps.xml file ?




Comment 2 Jeremy Katz 2003-02-13 20:46:37 UTC
redhat-config-kickstart was writing out bad kickstart configs.  Minimal doesn't
exist as a component, use Base instead.  This is fixed in newer versions of
redhat-config-kickstart

Comment 3 Mike McLean 2003-04-02 17:28:53 UTC
*** Bug 87738 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.