Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84189 - display configuration program will not start due to syntax error
Summary: display configuration program will not start due to syntax error
Keywords:
Status: CLOSED DUPLICATE of bug 82710
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86
Version: 9
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-13 08:59 UTC by Bernard Johnson
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:46 UTC


Attachments (Terms of Use)
fix for syntax error (deleted)
2003-02-13 09:01 UTC, Bernard Johnson
no flags Details | Diff

Description Bernard Johnson 2003-02-13 08:59:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
Attempting to start the display configuration program by the menu results in the
program trying to start but terminating with no message.

Attempting to run 'redhat-config-xfree86' gives the following error message:
  File "/usr/share/redhat-config-xfree86/xconf.py", line 357
    current_card_driver = current_card.getCardData()["DRIVER"]
                      ^
SyntaxError: invalid syntax


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Attempt to run the display configuration program from the menu
2.  OR Attempt to run 'redhat-config-xfree86'
3.
    

Actual Results:  If run from the menu, program terminates with no feedback.  If
run from the command line, the included error message is printed to the terminal.

Expected Results:  The display configuration program should start.

Additional info:

rpm -q redhat-config-xfree86
redhat-config-xfree86-0.7.2-2

Comment 1 Bernard Johnson 2003-02-13 09:01:29 UTC
Created attachment 90043 [details]
fix for syntax error

Applying this patch to /usr/share/redhat-config-xfree86/xconf.py fixes the
problem

Comment 2 Mike A. Harris 2003-02-13 10:53:49 UTC

*** This bug has been marked as a duplicate of 82710 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.