Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84187 - Segmentation fault when erasing old kernel
Summary: Segmentation fault when erasing old kernel
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-13 07:34 UTC by Stephen Rasku
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-07 23:46:38 UTC


Attachments (Terms of Use)
strace output (deleted)
2003-03-28 22:40 UTC, Stephen Rasku
no flags Details
rpm output (deleted)
2003-03-28 22:41 UTC, Stephen Rasku
no flags Details

Description Stephen Rasku 2003-02-13 07:34:12 UTC
Description of problem:

I get a segmentation fault when I try and remove an old kernel.  I do not get a
core.

Version-Release number of selected component (if applicable):
rpm-4.0.4-7x.18
kernel-2.4.18-24.7.x
glibc-2.3.1-43
glibc-common-2.3.1-43
glibc-devel-2.3.1-43

How reproducible:

All the time.

Steps to Reproduce:

As root:
1.rpm -e kernel-2.4.18-18.7.x.
    
Actual results:

Segmentation fault

Expected results:

Old kernel should be removed.

Comment 1 Jeff Johnson 2003-02-13 15:39:48 UTC
A "rpm --rebuilddb" with rpm-4.1 should fix your problem.

Otherwise, please reopen this bug, and give me a pointer
(i.e. URL, attachments won't work) to a tarball of your
database
    cd /var/lib
    tar czvf /tmp/rpmdb-84187.tar.gz rpm

Comment 2 Stephen Rasku 2003-02-13 18:34:07 UTC
This is turning into a dependency nightmare.  I have downloaded the following RPMs:

gnome-python2-1.99.11-8.i386.rpm         rhnlib-1.0-1.noarch.rpm
gnome-python2-canvas-1.99.11-8.i386.rpm  rhpl-0.51-1.i386.rpm
kdeadmin-3.0.3-3.i386.rpm                rpm-4.1-1.06.i386.rpm
libelf-0.8.2-2.i386.rpm                  rpm-build-4.1-1.06.i386.rpm
popt-1.7-1.06.i386.rpm                   rpm-python-4.1-1.06.i386.rpm
python-2.2.1-17.i386.rpm                 up2date-3.0.7-1.i386.rpm
rhn-applet-2.0.0-28.i386.rpm             up2date-gnome-3.0.7-1.i386.rpm


But I still have the following failed dependencies:
        gnome-python2-bonobo is needed by gnome-python2-1.99.11-8
        libart_lgpl_2.so.2   is needed by gnome-python2-1.99.11-8
        libbonobo-2.so.0   is needed by gnome-python2-1.99.11-8
        libbonobo-activation.so.4   is needed by gnome-python2-1.99.11-8
        libbonoboui-2.so.0   is needed by gnome-python2-1.99.11-8
        libgconf-2.so.4   is needed by gnome-python2-1.99.11-8
        libgnome-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomecanvas-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomeui-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomevfs-2.so.0   is needed by gnome-python2-1.99.11-8
        liblinc.so.1   is needed by gnome-python2-1.99.11-8
        libORBit-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomecanvas >= 2.0.0 is needed by gnome-python2-canvas-1.99.11-8
        pygtk2 >= 1.99.11 is needed by gnome-python2-canvas-1.99.11-8
        libart_lgpl_2.so.2   is needed by gnome-python2-canvas-1.99.11-8
        libgnomecanvas-2.so.0   is needed by gnome-python2-canvas-1.99.11-8
        pygtk2 >= 1.99.12-6 is needed by rhn-applet-2.0.0-28
        libgnomeui >= 2.0.3-1 is needed by rhn-applet-2.0.0-28
        libgnome >= 2.0.2-5 is needed by rhn-applet-2.0.0-28
        gnome-python2-gtkhtml2 is needed by rhn-applet-2.0.0-28
        libart_lgpl_2.so.2   is needed by rhn-applet-2.0.0-28
        libbonobo-2.so.0   is needed by rhn-applet-2.0.0-28
        libbonobo-activation.so.4   is needed by rhn-applet-2.0.0-28
        libbonoboui-2.so.0   is needed by rhn-applet-2.0.0-28
        libgconf-2.so.4   is needed by rhn-applet-2.0.0-28
        libgnome-2.so.0   is needed by rhn-applet-2.0.0-28
        libgnomecanvas-2.so.0   is needed by rhn-applet-2.0.0-28
        libgnomeui-2.so.0   is needed by rhn-applet-2.0.0-28
        libgnomevfs-2.so.0   is needed by rhn-applet-2.0.0-28
        liblinc.so.1   is needed by rhn-applet-2.0.0-28
        libORBit-2.so.0   is needed by rhn-applet-2.0.0-28
        librpm-4.0.4.so   is needed by gnorpm-0.96-14
        librpm-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpmdb-4.0.4.so   is needed by gnorpm-0.96-14
        librpmdb-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpmio-4.0.4.so   is needed by gnorpm-0.96-14
        librpmio-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0

I don't want to upgrade my whole system just to get rpm-4.1.  I have rebuilt the
database with rpm-4.0.4 and I have put the tar file you requested at:

http://richmond.tgivan.com/rpmdb-84187.tar.gz

The md5sum is:

3bb4d5360ad0bd1f80b3affaaafb7f92  rpmdb-84187.tar.gz

I don't know if that helps you or not.



Comment 3 Jeff Johnson 2003-02-20 17:01:03 UTC
There's nothing wrong with your database, so something
else is going on.

Are you using LDAP passwords? If so, then you need to
run nscd to avoid a segfault with statically linked
executables like /bin/rpm.

Can you upgrade/erase/install other packages?

Do other rpm commands "work"?

SOme other (i.e. not rpmdb) common factor needs to be identified.

Comment 4 Stephen Rasku 2003-02-21 18:07:30 UTC
I am not using LDAP passwords.  I can install packages but I can't upgrade or
erase packages.  I haven't done an exhaustive survey of all the rpm commands
but, of the commands I commonly use, only erase is broken.

If I can build RPM from source I should be able to determine exactly where the
segfault is happening.  However, I want to avoid installing this test RPM over
the current rpm binary.  Can you give me a source RPM that turns debugging on
and installs to another location?  If you build a source RPM, does it keep the
build tree or does it remove it?

Comment 5 Stephen Rasku 2003-02-21 18:08:59 UTC
Another thing.  I just upgraded the shadow-utils package using up2date.  I don't
know how this works if rpm isn't working.

Comment 6 Jeff Johnson 2003-02-25 00:10:40 UTC
I still need some hint other than rpmdb to attempt
to reproduce this problem.

I don't have a src rpm with debugging symbols. There
are symbols aavailable by doing
    cd /usr/src/redhat/BUILD/rpm-4.2
    make install
after rebuilding. Otherwise, -vv output is often
enough to characterize a problem.

Comment 7 Stephen Rasku 2003-03-28 22:40:30 UTC
Created attachment 90774 [details]
strace output

I took a hint from bug 86047 and am attaching the strace file from:

    strace -o /tmp/strace.out rpm -evv kernel-2.4.18-18.7.x

I will attach the output from rpm in a separate attachment.

Comment 8 Stephen Rasku 2003-03-28 22:41:04 UTC
Created attachment 90775 [details]
rpm output

Comment 9 Stephen Rasku 2003-09-07 23:46:38 UTC
This was apparently fixed by the fix for bug 86047.


Note You need to log in before you can comment on or make changes to this bug.