Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84171 - No symbolic link from libodbcpsql.so and libodbcpsqlS.so
Summary: No symbolic link from libodbcpsql.so and libodbcpsqlS.so
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: unixODBC
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fernando Nasser
QA Contact: David Lawrence
URL:
Whiteboard:
: 98575 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-13 00:22 UTC by Need Real Name
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-17 20:04:01 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-02-13 00:22:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
To get PostgreSQL to work with unixODBC, I had to modify my /etc/odbcinst.ini:
[PostgreSQL]
Description	= ODBC for PostgreSQL
Driver		= /usr/lib/libodbcpsql.so.1
Setup		= /usr/lib/libodbcpsqlS.so.1

This differs from most documentation on the web that state that
/etc/odbcinst.ini should look more like this:
[PostgreSQL]
Description	= ODBC for PostgreSQL
Driver		= /usr/lib/libodbcpsql.so
Setup		= /usr/lib/libodbcpsqlS.so

I also found out that I had to leave /etc/odbc.ini empty but that the .odbc.ini
should be filled in to something like this:
[ODBC Data Sources]
TEMPLATE1 = Template Database
 
[TEMPLATE1]
Database = template1
Servername = localhost
Debug = 1
CommLog = 1
ReadOnly = 0
Port = 5432
Driver = PostgreSQL


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.
    

Actual Results:  See above

Additional info:

Comment 1 Patrick Macdonald 2003-02-13 17:19:03 UTC
Fernando, please handle

Comment 2 Fernando Nasser 2003-02-17 20:04:01 UTC
Hi,

You have to install the  unixODBC-devel  package as well.   
If you do this you don't have to specify the ".1"s.


W.r.t. you .odb.ini file it seems to be working as expected.  
You must create a data source for the database you want to
connect to (as with any ODBC).  There are graphical tools 
to help you do that.  Have you checked the html documentation
that is installed in /usr/share/doc/unixODBC-2.2.3/doc ?

Regards,

Comment 3 Fernando Nasser 2003-07-04 17:02:20 UTC
*** Bug 98575 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.