Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84169 - sytems hangs during startup with demand dial ppp interface
Summary: sytems hangs during startup with demand dial ppp interface
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-13 00:09 UTC by Martin Cheatle
Modified: 2015-01-08 00:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-16 16:15:31 UTC


Attachments (Terms of Use)

Description Martin Cheatle 2003-02-13 00:09:13 UTC
Description of problem:
sytems hangs during startup with demand dial ppp interface

Version-Release number of selected component (if applicable):


How reproducible:
Every Time

Steps to Reproduce:
1.enable on boot startup for interface
2.
3.
    
Actual results:
System attempts to start ppp interface and sits there whating to dial if it
fails it just waits.

Expected results:
if the system fails to dial the interface skip and retry in the background

Additional info:
looking into this problem i found that the line in
/etc/sysconfig/network-scripts/ifup-ppp
that reads 
[ "${TYPE}" = "xDSL" ] || exec /sbin/ppp-watch "${DEVICE}" "$@"
the system hangs because to many options are being passed to ppp-watch
placing a echo before that line taht reads
echo "${DEVICE}" "$@"
revealed that the following was being passed

ppp0 ifcfg-ppp0 boot

by changing the line to read
[ "${TYPE}" = "xDSL" ] || exec /sbin/ppp-watch "${DEVICE}" "$2"
and changeing the echo to reflect this 
echo "${DEVICE}" "$2"

ppp0 boot

are passed to ppp-watch and the system boots Ok every time.

Comment 1 Thomas Woerner 2004-08-16 16:15:31 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.