Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84165 - Implement: service sendmail reload
Summary: Implement: service sendmail reload
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-12 22:34 UTC by Oliver Schulze L.
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-28 11:15:56 UTC


Attachments (Terms of Use)
Patch for sendmail-8.11.6-25.73 (deleted)
2003-06-26 00:28 UTC, Oliver Schulze L.
no flags Details | Diff

Description Oliver Schulze L. 2003-02-12 22:34:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

Description of problem:
It would be nice, if the sendmail service have the reload option.
So, if you change your /etc/mail/access or /etc/mail/virtusertable files, you
can issue a command like this:
# service sendmail reload
to make the changes take effect

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service sendmail reload
2. reload is not a recognized option
3.
    

Additional info:
This will help a mail server response, since you don't need to make your
mailserver unavailable for a couple of seconds or even kill existing sendmail
processes when you change a simple line in your config file.

Comment 1 Florian La Roche 2003-06-25 23:00:39 UTC

*** This bug has been marked as a duplicate of 98016 ***

Comment 2 Stephen Samuel 2003-06-25 23:18:57 UTC
Note that you don't need to reload sendmail to have it recognize changes to most
database files.

Doing a 'make ' in /etc/mail will enable changes to  things like the
virtusertable  and access.
Running 'newaliases' will activate changes to /etc/aliases.

Note that my patch does not try to rebuild databases (I'm now rethinking not
doing that in my patch).

BTW: I think that the reason why your patch was marked a duplicate of mine may
be   that  mine is for an active version of RH and/or includes a patch.

Comment 3 Oliver Schulze L. 2003-06-26 00:28:08 UTC
Created attachment 92624 [details]
Patch for sendmail-8.11.6-25.73

This is a patch for sendmail-8.11.6-25.73 for RH7.3
I ported the patch posted in bug #98016

Comment 4 Thomas Woerner 2004-01-28 11:15:56 UTC
Fixed in rawhide in rpm sendmail-8.12.11-1, or newer.


Note You need to log in before you can comment on or make changes to this bug.