Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84161 - autofs tries to get map from yp instead of ldap
Summary: autofs tries to get map from yp instead of ldap
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-12 21:59 UTC by Chris Hedemark
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-26 21:21:12 UTC


Attachments (Terms of Use)

Description Chris Hedemark 2003-02-12 21:59:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I have found this issue on other versions but it does not yet seem to be a
reported bug on 8.0.

I am authenticating against LDAP (works fine) but the automounter is confused in
thinking that the automount maps should come from yp instead of ldap.

Clearly he's getting something right (see results), but the yp bit messes things
up.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run "authconfig" and authenticate against an LDAP server
2. Set up auto.home in LDAP
3. Log in as an LDAP user.
    

Actual Results:  [root@moby root]# service autofs status
Configured Mount Points:
------------------------
/usr/sbin/automount /ldhome yp ldap ldap.cc3.com:ou=auto.home,dc=cc3unix,dc=com 

Active Mount Points:
--------------------
[root@moby root]# su - chrish
su: warning: cannot change directory to /ldhome/chrish: No such file or directory
-bash-2.05b$ 


Expected Results:  /ldhome/chrish should be mounted when user chrish logs in.

Additional info:

I have an enterprise support contract on this machine.

Comment 1 Chris Hedemark 2003-03-18 19:42:37 UTC
I have to confirm but I think this may have been caused by the ldap migration
scripts (bundled in RHL) which incorrectly create auto.master entries with a
space where a colon should go to separate fields.  I manually adjusted the value
accordingly and everything started working on its own.

Comment 2 Nalin Dahyabhai 2003-03-26 21:21:12 UTC
This appears to be a configuration error in the original /etc/auto.master file
which was passed to the migration script, as I was able to duplicate the
behavior you're describing by removing the colon between "ldap" and the
directory server's hostname and running the migration script again.

With the colon reintroduced, the migration script produced the desired LDIF,
which when imported into a directory server was properly read by the
autofs-ldap-auto-master helper and the init script.  Closing as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.