Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84146 - Scanning PCI bus when no PCI present causes Signal 11
Summary: Scanning PCI bus when no PCI present causes Signal 11
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pciutils
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-12 20:02 UTC by Lee Olsen
Modified: 2014-03-17 02:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-12 20:50:50 UTC


Attachments (Terms of Use)
text file briefly describing bug identification and resolution (deleted)
2003-02-12 20:17 UTC, Lee Olsen
no flags Details

Description Lee Olsen 2003-02-12 20:02:12 UTC
Description of problem:Signal 11 in /sbin/loader


Version-Release number of selected component (if applicable):


How reproducible:Attempt to install Redhat 7.3 on a system *WITHOUT* a PCI bus


Steps to Reproduce:
1.Make a boot floppy per the installation manual
2.boot non-PCI system from floppy
3.enter "linux dd" at "boot:" prompt
    
Actual results:Signal 11 from /sbin/loader


Expected results:Menu box requesting a driver disk


Additional info:Entering "linux nousb dd" delays the crash to after loading
additional drivers

Comment 1 Bill Nottingham 2003-02-12 20:03:55 UTC
Can you try this with the phoebe beta?

Comment 2 Lee Olsen 2003-02-12 20:17:40 UTC
Created attachment 90038 [details]
text file briefly describing bug identification and resolution

Since 8.0 is out, a patch against 7.3 probably doesn't make much sense.
I hope the function name, pci_scan_bus, the fact that it is a one line
function,
and the problem (methods is NULL) should make resolving this straight forward.
Enjoy
Lee

Comment 3 Bill Nottingham 2003-02-12 20:50:50 UTC
Fixed in 2.1.10-7, thanks!


Note You need to log in before you can comment on or make changes to this bug.