Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84113 - php-4.2.2-15 can not find db3 and refuses to --rebuild
Summary: php-4.2.2-15 can not find db3 and refuses to --rebuild
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-12 14:04 UTC by d. johnson
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:44 UTC


Attachments (Terms of Use)
Config.log file from a failed build (deleted)
2003-02-13 21:54 UTC, d. johnson
no flags Details

Description d. johnson 2003-02-12 14:04:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030203

Description of problem:
./configure is looking for libdb3 or libdb-3, neither of which is found in
phoebe or rawhide.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild php-4.2.2-15.src.rpm
2.
3.
    

Actual Results:  After running ./configure ...

checking for db_create in -ldb... no
checking for db_create in -ldb-3... no
checking for db_create in -ldb3... no
configure: error: cannot find necessary library
error: Bad exit status from /var/tmp/rpm-tmp.80673 (%build)


Expected Results:  Profit!

Additional info:

One line fix to resolve:

--- php.spec    2003-02-10 09:13:10.000000000 -0600
+++ php.spec.dj3        2003-02-12 07:35:59.000000000 -0600
@@ -256,7 +256,7 @@
        --disable-rpath \
        --enable-inline-optimization \
        --with-bz2 \
-       --with-db3 \
+       --with-db \
        --with-curl \
        --with-dom=%{_prefix} \
        --with-exec-dir=%{_bindir} \

Comment 1 d. johnson 2003-02-12 18:58:26 UTC
The above makes php compile, but does not permit php to use db functions.  Do
not use the above.  Appending "-ldb -lpthread" to LIBS (in the .spec) may work.


Comment 2 d. johnson 2003-02-12 19:35:54 UTC
Latest/stable php (4.3.0) compiles fine.  (this may be preferable to the ugly
cludge listed above).

Comment 3 Joe Orton 2003-02-13 16:45:21 UTC
Do you have the db4-devel package installed? db_create should be found in the
-ldb provided by db4-devel. Can you attach the build-cgi/config.log produced a
--rebuild which failed as above?

Comment 4 d. johnson 2003-02-13 21:54:26 UTC
Created attachment 90068 [details]
Config.log file from a failed build

Yes, I do have db4-devel-4.0.14-18 installed.  The above attachment is from "%
rpmbuild --rebuild php-4.2.2-16.src.rpm"

Comment 5 Joe Orton 2003-02-14 08:49:35 UTC
Curious.  I can link against -ldb without needing -lpthread on my Phoebe system.
You're also using CC=/usr/local/bin/gcc - have you tried CC=/usr/bin/gcc?
Or maybe the -18 db4 package breaks this.

Comment 6 Joe Orton 2003-02-14 09:02:09 UTC
Yeah, looks like this was a transient breakage in db4-devel.

*** This bug has been marked as a duplicate of 83434 ***

Comment 7 d. johnson 2003-02-16 06:27:10 UTC
Just FYI,  I'm using /usr/local/bin/gcc to take advantage of ccache.  (It simply
caches from gcc-3.2.1-7)

Comment 8 Red Hat Bugzilla 2006-02-21 18:51:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.