Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 841 - IPX interfaces on eth0 not started by "ifup eth0"
Summary: IPX interfaces on eth0 not started by "ifup eth0"
Keywords:
Status: CLOSED DUPLICATE of bug 205
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-15 14:24 UTC by B. K. Oxley (binkley)
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-01-15 16:31:08 UTC


Attachments (Terms of Use)

Description B. K. Oxley (binkley) 1999-01-15 14:24:36 UTC
After some checking, a shell hacker was a little whacky
with mixing eval/shell vars/program args.  He uses "802_3"
as the argument to ipx_interface, but it should be "802.3"
(for example, same true for other itfs).  I checked the
latest initscripts on rufus, and same bug.  Here's the
fixed file, ifup-ipx:

#!/bin/bash
# configures IPX on $1 if appropriate

PATH=/sbin:/usr/sbin:/bin:/usr/bin

if [ "$1" = "" ]; then
	echo "usage: $0 <net-device>"
	exit 1
fi

if [ ! -x /usr/bin/ipx_interface ] ; then
	# cannot configure IPX with non-existant utilities
	exit 0
fi

. /etc/sysconfig/network

case $IPX in yes|true) ;; *) exit 0 ;; esac

cd /etc/sysconfig/network-scripts
. network-functions

CONFIG=$1
[ -f "$CONFIG" ] || CONFIG=ifcfg-$CONFIG
source_config

for frametype in 802_2 802_3 ETHERII SNAP ; do
    # Yes, this kind of evaluation is really necessary to
do this.
    # Welcome to shell programming...  No, we were not
smoking some
    # particularly good floppies while we wrote this.  :-)
    case $(eval echo $(echo \$`echo IPXACTIVE_$frametype`))
in
	yes|true)
		case $(eval echo $(echo \$`echo
IPXPRIMARY_$frametype`)) in
		    yes|true) primary=-p ;;
		    *) primary= ;;
		esac
		# bozos... --bko
		case $frametype in
			802_2 ) real_frametype=802.2 ;;
			802_3 ) real_frametype=802.3 ;;
			ETHERII ) real_frametype=EtherII ;;
			* ) real_frametype=$frametype ;;
		esac
		/usr/bin/ipx_interface add $1 $primary
$real_frametype \
		  $(eval echo $(echo \$`echo
IPXNETNUM_$frametype`))
		;;
    esac
done

exit 0

Comment 1 Bill Nottingham 1999-01-15 16:31:59 UTC
*** This bug has been marked as a duplicate of 205 ***


Note You need to log in before you can comment on or make changes to this bug.