Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84091 - (vte) Selection kills clipboard
Summary: (vte) Selection kills clipboard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-12 02:22 UTC by Pete Zaitcev
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: FC-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-30 04:04:34 UTC


Attachments (Terms of Use)

Description Pete Zaitcev 2003-02-12 02:22:37 UTC
Description of problem:

Selection kills clipboard.

Version-Release number of selected component (if applicable):

vte-0.10.10-1
gnome-terminal-2.1.4-1

How reproducible:

100%

Steps to Reproduce:
0. Run "cat" and type some garbage to have something to copy and paste
1. Select something ("A")
2. Shift+Ctrl+C
3. Shift+Ctrl+V  <---- copied text "A" pastes
4. Select something else ("B")
5. Shift+Ctrl+V  <---- pastes "B" instead of "A"!

Actual results:

Pastes "A"

Expected results:

Should paste "B"

Additional info:

I do not recall this bug in first Phoebe. This must be an unintended
consequence of a bugfix. There were two or three clipboard handling bugs
fixed in vte for Phoebe-2.

Comment 1 Pete Zaitcev 2003-02-12 02:24:17 UTC
I am sorry, I mixed up "Expected" and "Actual" results.
"Steps to reproduce" section has correct sequence.


Comment 2 Warren Togami 2005-04-09 01:59:03 UTC
Is this still an issue in FC3 or FC4?

Comment 3 Pete Zaitcev 2005-04-09 04:21:15 UTC
It still happens.

vte-0.11.12-1
gnome-terminal-2.10.0-1

I'm not suprised that nobody notices, very few people use clipboard
with gnome-terminal. Most normal hackers just middle-button away...


Comment 4 Warren Togami 2005-04-09 04:46:46 UTC
I personally use the clipboard very often, sometimes copy huge amounts of
scrollbacks manually using the clipboard to paste into gedit, and I haven't seen
anything like this.

Please be sure to file this along with reproduce procedure upstream.  We sure as
hell don't have resources to fix vte in RH.  I am only "owning" vte now to
handle bug triage.

Comment 5 Pete Zaitcev 2006-06-30 04:04:34 UTC
This is fixed in FC-5:

vte-0.12.1-1.fc5.1
gnome-terminal-2.14.1-1.fc5.1



Note You need to log in before you can comment on or make changes to this bug.