Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84085 - VIA VT82xxx sound support driver not installing properly
Summary: VIA VT82xxx sound support driver not installing properly
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 8.0
Hardware: athlon
OS: Linux
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
Depends On:
TreeView+ depends on / blocked
Reported: 2003-02-12 00:29 UTC by Robert Hollingsworth
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2003-02-12 01:54:52 UTC

Attachments (Terms of Use)

Description Robert Hollingsworth 2003-02-12 00:29:21 UTC
Description of problem: Linux reports device /dev/dsp not found at startup of 
KDE and Gnome desktop interfaces. Sound configuration shows module for VIA and 
AC97 codec as active in KDE control panel. Recompile of kernel has not helped.

Version-Release number of selected component (if applicable):
RH Linux 2.4.18-14 and 2.4.18-24 kernel patch. 

How reproducible:
two different computers with two different versions of DFI MB with the VIA 
VT8233ACD chipset. I tried multiple times to install on each machine. I 
checked the PCs by booting Windows and loading the VIA 4 in 1 driver, sound 
worked correctly, ruling out hardware failure. Driver code is on system, it 
just does not seem to be connected to the Kernel. 

Steps to Reproduce:
1.Load Linux on PC with VIA chipset
2.Message at user startup indicates sound driver not found /dev/dsp sets to 
null file destination.
3.try to configure sound it reports driver not installed. Source code for 
driver is in 8.0 release. Module.config does not have alias for drivers either.
Actual results:

Expected results:

Additional info:
I can help with this problem by testing and probing systems. Send me E-mail if 
I can be of help.

Comment 1 Bill Nottingham 2003-02-12 01:54:52 UTC
This is fixed in the Phoebe beta kernel.

Note You need to log in before you can comment on or make changes to this bug.