Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84084 - jpilot crashes when entering password
Summary: jpilot crashes when entering password
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: jpilot
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-12 00:20 UTC by Stephen Rasku
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-14 12:32:34 UTC


Attachments (Terms of Use)

Description Stephen Rasku 2003-02-12 00:20:17 UTC
No matter what password I enter (even no password) to view hidden records, it
will crash jpilot.

Version-Release number of selected component (if applicable):

jpilot-0.99.2-11

How reproducible:

All the time
Steps to Reproduce:
1. Start jpilot
2. Select "View | Hide-Show Private Records"
3. Enter any password
    
Actual results:

pilot: relocation error: jpilot: symbol __ctype_tolower_loc, version GLIBC_2.3
not defined in file libc.so.6 with link time reference

Expected results:

jpilot should not crash.

Additional info:

I have not successfully linked with my handheld yet.  When I try and perform a
sync with jpilot, the Palm displays:

The desktop HotSync software does not support the password on this handheld. 
You must upgrade your desktop software or remove the password from the handheld.

Comment 1 Jakub Jelinek 2003-02-12 08:28:33 UTC
Do you have glibc-2.3 or later installed?

Comment 2 Stephen Rasku 2003-02-13 06:02:13 UTC
Now I do.  And it works.

How was I able to install jpilot without installing glibc-2.3? I didn't use
--force or --nodeps and it looks like it requires it:

libc.so.6(GLIBC_2.3)

Comment 3 Ngo Than 2003-02-14 12:32:34 UTC
since it works now, i close it.


Note You need to log in before you can comment on or make changes to this bug.