Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84079 - application/ogg MIME Type to be added
Summary: application/ogg MIME Type to be added
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailcap
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
: 98984 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-11 22:22 UTC by Linus Walleij
Modified: 2014-03-17 02:34 UTC (History)
3 users (show)

Fixed In Version: 2.1.14-1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-18 23:56:08 UTC


Attachments (Terms of Use)

Description Linus Walleij 2003-02-11 22:22:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The application/ogg MIME Type has been registered with the IANA, see
http://www.iana.org/assignments/media-types/application/ Its corresponding RFC
is approved by the IESG and is only awaiting number assignment and publication.
So application/x-ogg should be replaced with application/ogg in the mime.types
file and similar (magic) files.

application/x-ogg is associated with the filename extension .ogg in RedHat, but
does not appear in the Apache source file, so I guess this is the place to
complain, otherwise send me upstreams, thanks.

Comment 1 Michael A. Peters 2003-03-05 12:45:20 UTC
http://www.vorbis.com/faq.psp#mimetype
They list the mime type Red Hat uses as the proper mime type.

Comment 2 Bill Nottingham 2003-03-06 03:05:56 UTC
And, until upstream recommends something else, I doubt we'll change it.

Comment 3 Linus Walleij 2003-03-06 18:33:45 UTC
I represent the Ogg Vorbis community in these issues. We ("the upstream") have
now changed said webpage in accordance to what I said earlier. This has also
been reported in Ogg Traffic earlier, see
http://www.vorbis.com/ot/20030217.html#id2728505

Comment 4 Ralph Giles 2003-05-16 23:49:03 UTC
Just as an update, our rfc documenting the Ogg format and the application/ogg
mimetype have been released  by the IETF. Please see
http://ietf.org/rfc/rfc3534.txt or a description of the mimetype and
http://ietf.org/rfc/rfc3533.txt on the ogg file format itself.

Please do update your mimetypes entry; this will really help us move the the
migration through.

Comment 5 Bill Nottingham 2003-05-18 23:56:08 UTC
Added, will be in 2.1.14-1.

Comment 6 Bill Nottingham 2003-07-11 16:53:27 UTC
*** Bug 98984 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.