Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84055 - Should search the /etc/rpm/platform file under the root-dir
Summary: Should search the /etc/rpm/platform file under the root-dir
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-11 17:08 UTC by Enrico Scholz
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-13 16:04:29 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2003-02-11 17:08:19 UTC
Description of problem:

When using the '--root=...' option, rpm reads the platform-information from the
toplevel /etc/rpm/platform file. This is bad and forces the usage of the
'--ignorearch' switch when installing cross-arch packages.

It would be better when rpm searches the platform-file under the given
root-directory.


Version-Release number of selected component (if applicable):

rpm-4.2-0.65


Steps to Reproduce:
1. D=/foobar
2. mkdir -p $D/var/lib/rpm $D/etc/rpm
3. echo 'arm-unknown-linux' >$D/etc/rpm/platform
4. rpm --root=$D --initdb
5. rpmbuild --rebuild --target=arm foobar.src.rpm
6. rpm --root=$D -U foobar.arm.rpm
    
Actual results:

rpm tells 'package foobar.arm.rpm is intended for a arm architecture'


Expected results:

rpm installs the package

Comment 1 Jeff Johnson 2003-02-13 16:04:29 UTC
rpm determines arch very, very early so that per-arch
configuration can be determined. There's no easy way to
do this after the chrott(2) in order to support cross-platform
installs.

Try
    --ignorearch  don't verify package architecture



Note You need to log in before you can comment on or make changes to this bug.