Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84049 - init.ipv6-global uses ipv6_test which does not exist
Summary: init.ipv6-global uses ipv6_test which does not exist
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-11 15:26 UTC by John van Krieken
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-11 17:14:18 UTC


Attachments (Terms of Use)

Description John van Krieken 2003-02-11 15:26:14 UTC
Description of problem:
init.ipv6-global uses ipv6_test which does not exist.
This function used to be defined in network-functions-ipv6.

Version-Release number of selected component (if applicable):
6.95-1

How reproducible:
Try to using IPv6

Steps to Reproduce:
1. add NETWORKING_IPV6="yes" to /etc/sysconfig/network
2. cd /etc/init.d
3. sh network restart
    
Actual results:
# ./network restart
/etc/sysconfig/network-scripts/init.ipv6-global: line 132: ipv6_test: command
not found
Shutting down interface eth0:                              [  OK  ]
Shutting down interface eth1:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
/etc/sysconfig/network-scripts/init.ipv6-global: line 139: ipv6_test: command
not found
/etc/sysconfig/network-scripts/init.ipv6-global: line 57: ipv6_test: command not
found
Setting network parameters:                                [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Bringing up interface eth1:                                [  OK  ]
/etc/sysconfig/network-scripts/init.ipv6-global: line 85: ipv6_test: command not
found

Expected results:
None of the command not found errors


Additional info:
(doesn't work in Mandrake 9.0 either)

Comment 1 Bill Nottingham 2003-02-11 17:14:18 UTC
This should be fixed in current rawhide initscripts

Comment 2 John van Krieken 2003-02-11 17:54:08 UTC
I concur, just upgraded to 7.07-1 and looks fine,
sorry for not looking carefully enough.


Note You need to log in before you can comment on or make changes to this bug.