Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84041 - no password confirm field for both RHN Proxy/Satellite installers
Summary: no password confirm field for both RHN Proxy/Satellite installers
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other
Version: RHN Stable
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Todd Warner
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-11 13:15 UTC by Patrick C. F. Ernzer
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:43 UTC


Attachments (Terms of Use)
Proxy password confirm patch (deleted)
2003-03-13 16:48 UTC, Bret McMillan
no flags Details | Diff
Satellite confirm password patch (deleted)
2003-03-13 16:49 UTC, Bret McMillan
no flags Details | Diff

Description Patrick C. F. Ernzer 2003-02-11 13:15:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
can we please add a password confirmation field in the RHN Proxy installer?

Version-Release number of selected component (if applicable):
sing rhn-proxy-1.1-62-redhat-linux-as-i386-2.1.iso with md5 of
1cdfe2e3caab53d86ed083d01b7f005e

How reproducible:
Always

Steps to Reproduce:
1. launch GUI installer via ssh (proxy to be is headless)
2. enter a password
3. mistyope during pasword entering
    

Actual Results:  expected password is not set, lots of pain that can easily be
avoided

Expected Results:  a password confirmation field as to force the user to type
his password twice

Additional info:

Comment 1 Todd Warner 2003-02-28 05:54:04 UTC
issue in both the RHN Proxy and RHN Satellite servers. Adding to Tracking bugs
and acknowledging.

Comment 2 Bret McMillan 2003-03-13 16:48:34 UTC
Created attachment 90584 [details]
Proxy password confirm patch

Here's a patch for the proxy installer.

Comment 3 Bret McMillan 2003-03-13 16:49:30 UTC
Created attachment 90585 [details]
Satellite confirm password patch

Here's the patch for the satellite installer.

Comment 4 Todd Warner 2003-03-17 19:31:57 UTC
bretm's patch applied... punting to QA.

Comment 5 Greg DeKoenigsberg 2003-04-11 15:01:03 UTC
RHN 3.0.0

Comment 6 Todd Warner 2003-05-05 23:40:36 UTC
Split up bug... this is now, RHN Proxy installer only.
related to bug 90254

Done... in CVS... untested.

Comment 7 Todd Warner 2004-01-08 04:00:05 UTC
actually did exist, it was just called a challenge password and was
never used.

More or less applied bretm's patch.

NOTE, this was really a duplicate of 81237 I just never really put it
together for some reason.


*** This bug has been marked as a duplicate of 81237 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:51:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.