Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84028 - redhat-config-date has issues with UTC=1 in /etc/sysconfig/clock
Summary: redhat-config-date has issues with UTC=1 in /etc/sysconfig/clock
Keywords:
Status: CLOSED DUPLICATE of bug 72149
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-11 03:09 UTC by Brian "netdragon" Bober
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:42 UTC


Attachments (Terms of Use)

Description Brian "netdragon" Bober 2003-02-11 03:09:12 UTC
Description of problem:

Here was what my /etc/sysconfig/clock had because of redhat-config-date:

redhat-config-date doesn't recognize UTC=1 though... So it 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
Edit /etc/sysconfig/clock to this:
ZONE="America/New_York"
UTC=true
ARC=0
2.
run redhat-config-date (Use UTC should be checked) and then just click "OK"
3.
/etc/sysconfig/clock is now:
ZONE="America/New_York"
UTC=1
ARC=0
4. run redhat-config-date again and its no longer checked because
redhat-config-date doesn't recognize the value it set itself (UTC=1).

    
Actual results:
redhat-config-date sets UTC=1 into /etc/sysconfig/clock but doesn't recognize it.

Expected results:

redhat-config-date sets it to UTC=true


Additional info:
Also note that the time applet in Gnome 2 on RH8.0 becomes incorrect if you
enable UTC in its prefs. Don't know if that's related.

Comment 1 Brent Fox 2003-02-11 17:05:59 UTC
The latest redhat-config-date in Rawhide should handle the UTC and ARC fields
correctly.  This is basically a duplicate of bug #72149

*** This bug has been marked as a duplicate of 72149 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:42 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.