Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84015 - up2date reports installed rpm for xpdf still needed
Summary: up2date reports installed rpm for xpdf still needed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 23:51 UTC by Ben Sanchez
Modified: 2007-04-18 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 22:19:07 UTC


Attachments (Terms of Use)

Description Ben Sanchez 2003-02-10 23:51:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
I ran up2date today and updated several packages (all available since the new
kernal mod last week, which I ran by itself, then picked up the other rpm that
was available then, and the rest that came out since, including xpdf-1.01-10:1.

up2date and it's circular icon in the bottom right corner of my gnome bar on the
gnome desktop are telling me I need to update xpdf to the version I just installed.

When I run up2date, it checks the web, and finds I am up2date, as it should.
Problem is, the indication on the desktop does not go away, and if I click on
it, I still see up2date's window telling me I need to update the xpdf package.

This seems to be a bug, and I did not see any other reports of it on the web,
not exactly this bug anyway. downloading the new rpm from your support eratta
site and doing 

rpm -Fvh xpdf-1.01-10.i386.rpm

as root produces no output, just returns, so I guess that means it thinks there
was no refresh to do?

Thanks,
Ben Sanchez

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date, repeat until a package you just updated still says it needs update
2.done, this indication will not change,at least not over the course of a few hours.
3.
    

Additional info:

Comment 1 Daniel Veillard 2003-02-11 09:25:38 UTC
So far I have never seen this behaviour.
The steps indocated are not reproctible,
the applet does cache the content list of the rpm database
internally but also check the timestamp of the database
on the filesystem to invalidate the cache. The only way
I could imagine the behaviour indicated to happen is if the
time on the machine went backward at some point or if the
/var partition don't indicate modification time for the
database.
What happen if you restart the applet ?
Daniel 

Comment 2 Todd Warner 2005-09-23 22:19:07 UTC
no reponse in over 2 years. Closing.


Note You need to log in before you can comment on or make changes to this bug.