Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 84001 - rm queries the user before removing symbolic links to unwriteable files
Summary: rm queries the user before removing symbolic links to unwriteable files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 21:44 UTC by James Prewett
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-10 22:48:31 UTC


Attachments (Terms of Use)

Description James Prewett 2003-02-10 21:44:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1) Gecko/20030109

Description of problem:
/bin/rm behaves as if it is invoked as /bin/rm -i when removing symbolic links
to unwriteable files.

~$ which rm
/bin/rm

~$ touch /tmp/xxx
~$ ln -s /tmp/xxx ./xxx
~$ chmod 000 /tmp/xxx
~$ ls -ld .
drwxr-xr-x   25 download users        2560 Feb 10 14:28 .
~$ rm ./xxx
rm: remove symbolic link `xxx'?

Please note that rm is not aliased to rm -i (nor is there a function, etc that
would be changing which command actually gets used).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. touch /tmp/xxx
2. ln -s /tmp/xxx ./xxx
3. chmod 000 /tmp/xxx
4. rm ./xxx
    

Actual Results:  I get the message:
rm: remove symbolic link `xxx'?

Expected Results:  symbolic link should have been removed without prompting me

Additional info:

fileutils-4.1.9-11

Comment 1 Tim Waugh 2003-02-10 22:48:31 UTC
Seems to be fixed in coreutils in rawhide.


Note You need to log in before you can comment on or make changes to this bug.