Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83995 - gnome-terminal crases when setting tab to certain chars
Summary: gnome-terminal crases when setting tab to certain chars
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 20:57 UTC by P Jones
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-17 19:34:02 UTC


Attachments (Terms of Use)

Description P Jones 2003-02-10 20:57:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have selecte language en_GB.
with a directory name with non-breaking spaces in it.
Bash sets the window title - same as tab name- to the directory name (with user
and machine name)

This crases.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login in en_GB
2.create directory (see addition info if needed)
3.cd to that directory
4.right click, new tab (must be in two+ tabs)
    

Additional info:

Run this to get a "foo bar" directory with the NBSP in it:
cat << EOF | xxd -r | tar xvz
0000000: 1f8b 0800 4a12 483e 0003 edce b111 8240  ....J.H>..��...@
0000010: 1086 d12b 850e 5c90 e3ea c119 cd98 9b01  ..�+..\.���.�...
0000020: e9c7 52bd 4003 138d 307a 2ff9 82fd 83bd  ��R.@...0z/�.�..
0000030: d5fa b8cc eb29 1d28 628c 5272 6bb4 968f  ��.��).(b.Rrk...
0000040: bea4 28d3 3044 dfc7 794c 2d53 ee53 978f  ..(�0D��yL-S�S..
0000050: 7cea 6ddf eef3 da75 69a9 fb76 fdb2 fb75  |�m����ui.�v�.�u
0000060: 0700 0000 0000 0000 0080 3f7a 0265 6708  ..........?z.eg.
0000070: b300 2800 00                             ..(..
EOF

Comment 1 P Jones 2003-02-10 21:03:48 UTC
Better command, sorry
cat << EOF | xxd -r | tar xvz
0000000: 1f8b 0800 4a12 483e 0003 edce b111 8240
0000010: 1086 d12b 850e 5c90 e3ea c119 cd98 9b01
0000020: e9c7 52bd 4003 138d 307a 2ff9 82fd 83bd
0000030: d5fa b8cc eb29 1d28 628c 5272 6bb4 968f
0000040: bea4 28d3 3044 dfc7 794c 2d53 ee53 978f
0000050: 7cea 6ddf eef3 da75 69a9 fb76 fdb2 fb75
0000060: 0700 0000 0000 0000 0080 3f7a 0265 6708
0000070: b300 2800 00 ..(..
EOF


Comment 2 Havoc Pennington 2003-02-13 17:40:30 UTC
I can't reproduce this; it beeps a lot, but doesn't seem to crash.
Perhaps I'm not using exactly the same version of vte.


Note You need to log in before you can comment on or make changes to this bug.