Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83976 - quotes in window titles not handled in saved session
Summary: quotes in window titles not handled in saved session
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 17:32 UTC by bcboy
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-11 14:05:47 UTC


Attachments (Terms of Use)

Description bcboy 2003-02-10 17:32:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Metacity hangs on start-up if there were quotes in a window title in
the previous session.

Exact behavior may depend on the title, since metacity attempts to
interpret it.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Start galeon
2.Go to www.google.com
3.Search for "file too large" (including quotes)
4. Exit gnome session
5. Log in.     

Actual Results:  Session start-up froze on metacity. Switching back to console,
it had spit up a warning about a bad "file" attribute in this line:

<window id="117f000001000104486417700000021040000" class="galeon_browser"
name="Galeon" title="Google Search: "ssh file too large" - Galeon" role=""
type="normal" stacking="2">

Editing the file under ~/.metacity/sessions to remove the quotes allowed the
session to start normally.

Additional info:

Comment 1 Havoc Pennington 2003-02-11 14:05:47 UTC
Fixed now.


Note You need to log in before you can comment on or make changes to this bug.