Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83955 - Cannot make ANY changes to the network configuration via subj module w/o receiving this error.
Summary: Cannot make ANY changes to the network configuration via subj module w/o rece...
Keywords:
Status: CLOSED DUPLICATE of bug 59017
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: redhat-config-network
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 14:52 UTC by Ron Tregaskis
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ron Tregaskis 2003-02-10 14:52:47 UTC
Description of problem:

Attempting to complete the network config via gnome.   Clicking on 'Apply' after
making any changes results in exception error:  Illegal argument type for
built-in operation.

Version-Release number of selected component (if applicable):  AS2.1


How reproducible:

Very - happens on all four of my servers, no matter the network config change
attempted.


Steps to Reproduce:
1.  Open gnome main menu Programs/System/Network Configuration; or the Start
Here window to System/Network Configuration
2.  Change the hosts, DNS, etc. 
3.  Click on Apply.
    
Actual results:

The following exception error and no changes applied -

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981,
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 936,
in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 848b268>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [       ]*alias[        ]+eth1[         ]+


Expected results:

Simply to make the config changes requested.

Additional info:

Comment 1 Harald Hoyer 2003-02-10 15:13:46 UTC

*** This bug has been marked as a duplicate of 59017 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.