Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83929 - Improvement of _ROOT_HAS_QUOTA checking in rc.sysinit
Summary: Improvement of _ROOT_HAS_QUOTA checking in rc.sysinit
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 05:35 UTC by SEKINE Tatsuo
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 13:25:04 UTC


Attachments (Terms of Use)

Description SEKINE Tatsuo 2003-02-10 05:35:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.1) Gecko/20021030 for
VineLinux 0vl6

Description of problem:
quota checking of / partition in rc.sysinit is not cool.
Because AWK have regex functionality, the combination of grep and awk
is not cool.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see /etc/rc.sysinit    

Actual Results:  rc.sysinit::286

# Possibly update quotas if fsck was run on /.
LC_ALL=C grep -E '[[:space:]]+/[[:space:]]+' /etc/fstab | \
    awk '{ print $4 }' | \
    LC_ALL=C grep -q quota
_ROOT_HAS_QUOTA=$?


Expected Results:  rc.sysinit::286

# Possibly update quotas if fsck was run on /.
LC_ALL=C awk '(($2 == "/") && ($4 ~ /quota/)){found = 1; exit;}
    END{ if (!found) exit 1; }' /etc/fstab
_ROOT_HAS_QUOTA=$?


Additional info:

Comment 1 SEKINE Tatsuo 2005-05-03 13:25:04 UTC
This is meaningless, so I closed this.



Note You need to log in before you can comment on or make changes to this bug.