Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83925 - csh.login specifies wrong readline conf file (inputrc)
Summary: csh.login specifies wrong readline conf file (inputrc)
Keywords:
Status: CLOSED DUPLICATE of bug 83924
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 04:57 UTC by Michael Wardle
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:41 UTC


Attachments (Terms of Use)

Description Michael Wardle 2003-02-10 04:57:00 UTC
Description of problem: 
/etc/csh.login tests for the existence of the user's readline configuration file (~/.inputrc), but sets it to the 
system-wide readline configuration file (/etc/inputrc) if the user's configuration file is found. 
 
Version-Release number of selected component (if applicable): 
setup-2.5.12-1 
tcsh-6.10-6 
readline-4.2a-4 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Change login shell to tcsh 
2. Log in 
3. Print the value of $INPUTRC 
     
Actual results: 
Value is /etc/inputrc. 
 
Expected results: 
Value is $HOME/.inputrc or unset. 
 
Additional info: 
This exists in Red Hat 7.3 thru 8.0.92.  I assume it still exists in the current version.

Comment 1 Michael Wardle 2003-02-10 05:05:37 UTC
A Bugzilla error occured while attempting to submit this the first time, 
so I resubmitted it.  It appears the original submission worked. 
 
Sorry for the dupe. 
 

*** This bug has been marked as a duplicate of 83924 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.