Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83924 - csh.login specifies wrong readline conf file (inputrc)
Summary: csh.login specifies wrong readline conf file (inputrc)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
: 83925 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-10 04:55 UTC by Michael Wardle
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version: 2.5.32-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-23 05:30:38 UTC


Attachments (Terms of Use)
set to ~/.inputrc if it exists else set to /etc/inputrc if that exists (deleted)
2003-02-10 05:08 UTC, Michael Wardle
no flags Details | Diff

Description Michael Wardle 2003-02-10 04:55:48 UTC
Description of problem: 
/etc/csh.login tests for the existence of the user's readline configuration file (~/.inputrc), but sets it to the 
system-wide readline configuration file (/etc/inputrc) if the user's configuration file is found. 
 
Version-Release number of selected component (if applicable): 
setup-2.5.12-1 
tcsh-6.10-6 
readline-4.2a-4 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Change login shell to tcsh 
2. Log in 
3. Print the value of $INPUTRC 
     
Actual results: 
Value is /etc/inputrc. 
 
Expected results: 
Value is $HOME/.inputrc or unset. 
 
Additional info: 
This exists in Red Hat 7.3 thru 8.0.92.  I assume it still exists in the current version.

Comment 1 Michael Wardle 2003-02-10 05:05:39 UTC
*** Bug 83925 has been marked as a duplicate of this bug. ***

Comment 2 Michael Wardle 2003-02-10 05:08:30 UTC
Created attachment 89958 [details]
set to ~/.inputrc if it exists else set to /etc/inputrc if that exists

Trivial patch showing a possible solution.

if ~/.inputrc is a file, set $INPUTRC to that
else if /etc/inputrc is a file, set $INPUTRC to that

Comment 3 Michael Wardle 2003-03-21 20:41:16 UTC
Please try to fix this for the next Red Hat release.  It's a very simple fix,
but in its current state, it causes problems for any tcsh user wanting to use
Emacs, gdb, bash, or any other program that uses readline.


Comment 4 Michael Wardle 2003-03-22 02:24:57 UTC
The smallest change, and the one which makes the csh login script equivalent
to the bash login script is to change:
if ( -f $HOME/.inputrc ) then
to
if ( ! $?INPUTRC && ! -f $HOME/.inputrc ) then


Comment 5 Bill Nottingham 2004-09-23 05:30:38 UTC
This was fixed in 2.5.32.


Note You need to log in before you can comment on or make changes to this bug.