Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83921 - grubby segmentation fault leaves upgrade unbootable
Summary: grubby segmentation fault leaves upgrade unbootable
Keywords:
Status: CLOSED DUPLICATE of bug 84128
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-10 03:34 UTC by Chris Ricker
Modified: 2008-01-17 17:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:41 UTC


Attachments (Terms of Use)
grub.conf that grubby segfaulted on (deleted)
2003-02-10 15:14 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2003-02-10 03:34:52 UTC
I just tried upgrading to pre-beta5 (mkinitrd 3.4.39-1)

After the upgrade, the system failed to boot. The upgrade had replaced the old
kernel with the new one, but left the old grub.conf in place. Looking through
grub.conf, it appears that the old grub.conf is because grubby segfaulted when
the kernel was upgraded.

Upgrading kernel-2.4.20-2.33.
/sbin/new-kernel-pkg: line 260:   534 Segmentation fault      /sbin/grubby --add
-kernel=$bootPrefix/vmlinuz-$version $INITRD --copy-default --title "$title" --a
rgs="root=$rootdevice" --remove-kernel="TITLE=$title"
/sbin/new-kernel-pkg: line 260:   545 Segmentation fault      /sbin/grubby --rem
ove-kernel=$bootPrefix/vmlinuz-$version

Comment 1 Jeremy Katz 2003-02-10 06:52:56 UTC
Could you attach the grub.conf?

Comment 2 Chris Ricker 2003-02-10 15:14:00 UTC
Created attachment 89970 [details]
grub.conf that grubby segfaulted on

This is the grub.conf on the system already which grubby didn't upgrade....

Comment 3 Jeremy Katz 2003-02-18 17:25:19 UTC
I don't see anything at all wrong with the grub.conf, but it sounds suspiciously
like bug 84128

*** This bug has been marked as a duplicate of 84128 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.