Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 838477 - [RFE] Allow editing of running virtual machine
Summary: [RFE] Allow editing of running virtual machine
Keywords:
Status: CLOSED DUPLICATE of bug 922377
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Omer Frenkel
QA Contact: yeylon@redhat.com
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-09 08:35 UTC by Andrew Cathrow
Modified: 2016-04-18 06:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-14 21:01:41 UTC
oVirt Team: ---
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)

Description Andrew Cathrow 2012-07-09 08:35:12 UTC
Allow VM to be edited while still running, with changes queued up to be applied when VM is next started

Comment 1 Yaniv Kaul 2012-07-09 08:45:36 UTC
Note that you actually want VDSM and friends (libvirt) to catch a reboot and turn it into shutdown and re-launch QEMU. This will allow an admin to (for example) increase the VM's memory and tell the user to reboot the VM whenever he's ready to do it and he'll get his updated parameters. VDSM will catch the reboot and turn it into shutdown, get the new parameters (memory) and re-launch the VM.

Comment 2 Scott Herold 2014-01-14 21:01:41 UTC

*** This bug has been marked as a duplicate of bug 922377 ***


Note You need to log in before you can comment on or make changes to this bug.