Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83813 - openvt can't execute progs in specified console
Summary: openvt can't execute progs in specified console
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: console-tools
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-09 08:20 UTC by hvv
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-23 21:12:50 UTC


Attachments (Terms of Use)

Description hvv 2003-02-09 08:20:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
Calling openvt e.g. like this:
openvt -c 10 -s /bin/bash
doesn't start new shell on the specified console - it just switches
to it. Same with the openvt from rh73.
  NB that 'open' from console-tools shipped with RH60 works just
fine - and I'm using it as a substitution for 'openvt' in RH73.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run 'openvt -c 8 -s /bin/sh' as root
    

Actual Results:  console#8 becomes current,- but nothing gets started there.

Expected Results:  console8 becomes current and shell starts there.

Additional info:

I use open/openvt to open log viewers and performance display tools
on consoles from 9 to 12.

Comment 1 Eido Inoue 2004-08-23 21:12:50 UTC
works for me on valid console #s that aren't in use (unless you use
--force) on current release


Note You need to log in before you can comment on or make changes to this bug.