Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83779 - Nautilus makes stale NFS folders on VFAT partition
Summary: Nautilus makes stale NFS folders on VFAT partition
Keywords:
Status: CLOSED DUPLICATE of bug 79842
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-08 11:38 UTC by Scott Otterson
Modified: 2015-01-08 00:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:39 UTC


Attachments (Terms of Use)

Description Scott Otterson 2003-02-08 11:38:49 UTC
Description of problem:

I have a local VFAT partition mounted to /sdat.  If, in nautilus, I'm in the folder:

  /sdat/pix/030208_miscTokyo

and if I make a new folder underneath with file->new folder called "tmp", then I
will see the folder in nautilus.  Then if I go to a terminal and type:

cp .bashrc /sdat/pix/030208_miscTokyo/tmp

I get the message:

cp: cannot create regular file `/sdat/pix/030208_miscTokyo/tmp/.bashrc': Stale
NFS file handle

However, I don't have this problem if I make the directory with:

  mkdir /sdat/pix/030208_miscTokyo/tmp

Also, nautilus does a folder making problem if I make a folder in my ext3 partition.

Version-Release number of selected component (if applicable):

2.06

How reproducible:

Every Time.

Comment 1 Alexander Larsson 2003-02-10 12:24:25 UTC
Totally crazy. There shouldn't be any NFS involved here at all.


Comment 2 Edward Kuns 2003-04-01 02:37:04 UTC
I have also seen this problem under Red Hat 8.0.  I have a dual-boot laptop with
a FAT32 partition shared by Win2k and RH8.0.  With the kernel installed
originally with RH8, I never saw this problem once no matter how much I did. 
After running up2date I began to see this exact problem.  It's very strange.  I
have not tried different update kernels for 8.0 to see where the problem began.
 I have not looked at any source code to see what might be going on.  But this
is a very real bug.

Actually, it's possible that this isn't the kernel.  I ran up2date on the laptop
for the first time roughly a week ago.  With original 8.0 packages I did not see
this.  After running up2date and updating EVERYTHING it suggested, I now see
this problem.

This problem and Bugzilla entry 79842 are most likely one and the same.


Comment 3 Alexander Larsson 2003-04-01 12:30:54 UTC
Yeah. They look like the same. And it's highly likely that this is a kernel
issue (since the other bug reproduced with shell commands), so i'm marking this
as a duplicate.


*** This bug has been marked as a duplicate of 79842 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:39 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.