Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83778 - KDevelop can't find mcopidl & artsc-config during intial configuration of the make files
Summary: KDevelop can't find mcopidl & artsc-config during intial configuration of the...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdevelop
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-08 10:31 UTC by Mark Gooch
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-09 22:48:13 UTC


Attachments (Terms of Use)

Description Mark Gooch 2003-02-08 10:31:34 UTC
From Bugzilla Helper:User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)Description of problem:Fresh installation of RH8.0 - 'out of the box'When a new (mdi) project is created in KDevelop, compilation fails because the makefile can't be created because KDevelop can't find mcopidl and artsc-config.KDevelop asks if aRts has been installed properly.The problem is either:- KDevelop's standard project template requires two system files which were not installed by Anaconda, or- KDevelop's standard project template configuration requires files that I don't need (specific to aRts), and I can't 'turn them off'When files are copied from another RH8.0 installation into /usr/bin, KDevelop works properly.Version-Release number of selected component (if applicable):How reproducible:AlwaysSteps to Reproduce:1.Install RH8.0, with KDevelop2.Open KDevelop3.Project -> New -> MDI4.( Ignore documentation indexing bux )5.Work through Wizard & Exit when project has been created6.Build->configure ( leaving options blank, as per default )7.Get error message    Actual Results:  KDevelop reports that a critical file mcopidl is missing, have you installed aRts correctly. When the file is installed in /usr/bin, it gives a similar message regarding artsc-config.Expected Results:  Build->configure should have found all required files in an out-of-the-box configurationAdditional info:Reproducibility - happens every time I tried to create a new project, with my KDevelop installationHaven't tried re-installing the system to see if it would pick up the extra files ( I was able to copy them from another RH8.0 installation on my laptop - then KDevelop works fine. )

Comment 1 Ngo Than 2003-02-09 22:48:13 UTC
you have to install arts/arts-devel if you want to have them.
it's not required and is not installed by default.


Note You need to log in before you can comment on or make changes to this bug.