Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83763 - Various problems with a Philips PCA645VC WebCam (USB)
Summary: Various problems with a Philips PCA645VC WebCam (USB)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL: http://www.zacinto.it/webcam.html
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 23:26 UTC by Antonio Sanna
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-23 20:00:45 UTC


Attachments (Terms of Use)
hwconf file from kudzu (deleted)
2003-02-07 23:28 UTC, Antonio Sanna
no flags Details
From the messages file (deleted)
2003-02-07 23:30 UTC, Antonio Sanna
no flags Details

Description Antonio Sanna 2003-02-07 23:26:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
The problem is twofold:
1) the video: kudzu detects correctly the USB webcam, writes the informations in
the /etc/sysconfig/hwconf file (see attachment) and activate an alias, but it
don't insert the informations in the /etc/modules.conf file.  Then, when I try
to use the webcam, for exemple with Gnomemeeting, the program can't accede to
the video1 device (in the video0 there is a TV card correctly configured from
kudzu with the exact line in the modules.conf file). The problem was present in
8.0 too: I go to the file /var/log/messages and I search the alias called from
modprobe, I find it, for exemple char-major-81-1, and I add the line "alias
char-major-81-1 pwc" to the modules.conf file. In this way it seems to work.

2) the audio: this webcam have a microphone integrated. After the video part,
kudzu detects the audio part, but there is immediatly a problem: it asks me more
than 20 times if I want install the new sound card WebCam, ecc. I say ok all the
times.  This time kudzu writes these lines to modules.conf file:

alias sound-slot-1 audio
post-install sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-1 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

(the sound-slot-0 is a Creative Sound Card that works perfectly). In the hwconf
file, instead, it writes 20 times the same thing (see attachment). This thing is
visible in the Hardware Browser utility (see the URL). 
In the /var/log/messages, when the audio is called, there is alway something of
similar to this:

(see the usbaudio.txt file)

I don't know if this thing is normal, but I'm not able to hear nothing from the
integrated microphone. Maybe I don't operate correctly?

Excuse me for the length: I hope -at least - to have been exhausting.


How reproducible:
Always

Steps to Reproduce:
1. I plug in the USB webcam
2. I try it, but the video1 device is not available
3. I don't hear nothing from the integrated microphone

Actual Results:  To make to work the webcam is a hard work ;-)

Expected Results:  The webcam works without my intervention.

Additional info:

The problem is the same with RedHat Psyche.

Comment 1 Antonio Sanna 2003-02-07 23:28:39 UTC
Created attachment 89937 [details]
hwconf file from kudzu

Comment 2 Antonio Sanna 2003-02-07 23:30:15 UTC
Created attachment 89938 [details]
From the messages file

Comment 3 Bill Nottingham 2005-09-23 20:00:45 UTC
In current releases, such as Fedora Core 4, the modules should be loaded
automatically via hotplug and udev, and the problem with multiple interfaces
being over-listed (for usb audio) has since been fixed.

Closing this bug out.


Note You need to log in before you can comment on or make changes to this bug.