Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83752 - Enh: add support for elf-32 binary dis-assembling
Summary: Enh: add support for elf-32 binary dis-assembling
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: binutils
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 22:14 UTC by Glen A. Foster
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-11 13:21:38 UTC


Attachments (Terms of Use)

Description Glen A. Foster 2003-02-07 22:14:03 UTC
Description of problem: IA64 supports 32-bit Intel instruction set emulation 
and ships a set of x86-compat-libs to allow 32-bit Intel code to run on IA64 
(and IPF).  Yet, running "objdump -d elf-32-format-file" fails on IA64, which 
is understandable since it's not the matching architecture.  However, 
instruction set emulation seems to warrant a case for adding support for dis-
assembling elf-32 binaries on an 64-bit Intel architecture.

Version-Release number of selected component (if applicable):
# rpm -qf $(which objdump)
binutils-2.11.90.0.8-12.2

How reproducible: 100% (always)

Steps to Reproduce:

... run these steps on an IA64/IPF system...
1. scp intel32bithost:/usr/bin/objdump /tmp
2. objdump -d /tmp/objdump
    
Actual results:

/tmp/objdump:  file format elf32-little

objdump: /tmp/objdump: no symbols
objdump: Can't disassemble for architecture UNKNOWN!

Comment 1 Jakub Jelinek 2003-02-11 13:21:38 UTC
Should be fixed in 2.13.90.0.18-2 and later (ATM -5).


Note You need to log in before you can comment on or make changes to this bug.