Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83747 - I have installed from ftp, but it asks me the CD (1, 2 or 3) to install a package
Summary: I have installed from ftp, but it asks me the CD (1, 2 or 3) to install a pac...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 21:28 UTC by Antonio Sanna
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-10 01:25:10 UTC


Attachments (Terms of Use)

Description Antonio Sanna 2003-02-07 21:28:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
I have installed Phoebe from a local ftp, but redhat-config-packages asks me the
CDs when I want install a new package: I don't know if this is a bug or an
enhancement, but it isn't a logical behavior, I think.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. I install Phoebe from ftp
2. I launch redhat-config-packages to install a new package

Actual Results:  redhat-config-packages asks me the CDs

Expected Results:  redhat-config-packages download the packages from ftp

Comment 1 Jeremy Katz 2003-02-10 01:25:10 UTC
You can do this by running with --tree=ftp://path/to/dir.  We don't preserve
information on method of installation due to the fact that in some cases it may
have sensitive information such as passwords for connection to the ftp site.

Comment 2 Miloslav Trmac 2003-02-10 15:15:30 UTC
Doesn't --tree need a .discinfo file? There is none on the FTP
mirrors.

Comment 3 Justin Georgeson 2003-02-24 04:47:58 UTC
I know this bug is closed already, but I would like to be able to use
redhat-config-packages with RedHat's ftp site, and here is the error I get using
the --tree parameter.

[root@dragonfly root]
# redhat-config-packages
--tree=ftp://ftp.redhat.com/pub/redhat/linux/beta/phoebe/en/os/i386/RedHat/RPMS/
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 160, in ?
    im = get_method(args)
  File "/usr/share/redhat-config-packages/config.py", line 55, in get_method
    return urlmethod.UrlInstallMethod(url)
  File "/usr/share/redhat-config-packages/urlmethod.py", line 59, in __init__
    f = urllib2.urlopen(self.url + dir + "/.discinfo")
  File "//usr/lib/python2.2/urllib2.py", line 138, in urlopen
    return _opener.open(url, data)
  File "//usr/lib/python2.2/urllib2.py", line 322, in open
    '_open', req)
  File "//usr/lib/python2.2/urllib2.py", line 301, in _call_chain
    result = func(*args)
  File "//usr/lib/python2.2/urllib2.py", line 930, in ftp_open
    fw = self.connect_ftp(user, passwd, host, port, dirs)
  File "//usr/lib/python2.2/urllib2.py", line 951, in connect_ftp
    fw = ftpwrapper(user, passwd, host, port, dirs)
  File "//usr/lib/python2.2/urllib.py", line 705, in __init__
    self.init()
  File "//usr/lib/python2.2/urllib.py", line 714, in init
    self.ftp.cwd(dir)
  File "//usr/lib/python2.2/ftplib.py", line 500, in cwd
    return self.voidcmd(cmd)
  File "//usr/lib/python2.2/ftplib.py", line 247, in voidcmd
    return self.voidresp()
  File "//usr/lib/python2.2/ftplib.py", line 222, in voidresp
    resp = self.getresp()
  File "//usr/lib/python2.2/ftplib.py", line 215, in getresp
    raise error_perm, resp
IOError: [Errno ftp error] 550 Failed to change directory.
[root@dragonfly root]
#

Comment 4 Mark Cooke 2003-03-15 11:30:31 UTC
I also know the bug is closed, but it would be nice from a usability perspective
for the 'Insert CD X' window to have an additional button to select an
alternative location.

This would prevent the user having to quit out, fire off a root shell, and
tediously re-select the package changes after restarting with a --tree flag.


Note You need to log in before you can comment on or make changes to this bug.