Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83740 - Shutdown doesn't work as expected
Summary: Shutdown doesn't work as expected
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: sysvinit
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 19:16 UTC by Wayne Pollock
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-20 20:03:44 UTC


Attachments (Terms of Use)

Description Wayne Pollock 2003-02-07 19:16:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
The /sbin/shutdown command allows shbutdowns after a delay.
During the delay period no logins are allowed.  However
shutdown fails to prevent other connections such as from
ftp.  (The command ftpshut does this but shutdown doesn't
invoke it.)  Shutdown should prevent ftp logins too, perhaps
all incomming TCP connections should be dis-allowed.

Another problem with delayed shutdown is that the warning message
issued fails to take into account the time interval used in the
"-t seconds" option.  For example:

    # shutdown -t 60 -r +10

will broadcast "System comming down for REBOOT in 10 minutes",
when of couse it should be "11 minutes".  Not using the "-t"
option is not a work-around since a second message at 1 minute
left is desirable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./sbin/shutdown -t 60 -r +10 "Test reboot"
2.ftp localhost
3.
    

Actual Results:  Time remaining message incorrect, and can still connect with FTP

Expected Results:  Correct time remaining (perhpas rounded to the nearest minute),
and new FTP connections dis-allowed.

Additional info:

Comment 1 Bill Nottingham 2005-04-19 18:22:23 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Comment 2 Wayne Pollock 2005-04-19 21:16:16 UTC
Please re-open for current release.  I have updared the release number to 9.

Comment 3 Bill Nottingham 2005-12-20 20:03:44 UTC
Realistically, this isn't something we're going to fix outside of the upstream
project - that is hosted at ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/.

Comment 4 David Lawrence 2007-06-22 02:18:11 UTC
Package name is now sysvinit in latest Fedora.


Note You need to log in before you can comment on or make changes to this bug.