Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83738 - self-conflicted packages continue to install
Summary: self-conflicted packages continue to install
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 18:56 UTC by Suzan Wassman
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 19:07:06 UTC


Attachments (Terms of Use)

Description Suzan Wassman 2003-02-07 18:56:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:

Testing for conflicts during RPM install does not behave as expected if conflict
is with a particular version of itself.

It seems that the install checks are inspecting the version trying to install as
well as the RPM database to determine conflicts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  rpm -i foo-2.1.0-8.i386.rpm
2.  (spec file for foo contains "Conflicts: foo < 2.5.0-0")
3.  rpm -Uvv foo-2.5.1-0.i386.rpm 
    

Actual Results:  foo successfully upgraded

Expected Results:  foo should NOT have upgraded since existing foo was <
2.5.0-0; it should have spouted an error with failed dependencies because of
package conflicts

Additional info:

Here's my system specs:
rpm-4.0.4-7x.18
kernel 2.4.18-5
RedHat 7.3

Comment 1 Paul Nasrat 2005-09-29 19:07:06 UTC
[pauln@enki SPECS]$ sudo rpm --test -ivh ../RPMS/foo-2.5.1-1.i386.rpm
error: Failed dependencies:
        foo < 2.5.0-0 conflicts with foo-2.5.1-1.i386
[pauln@enki SPECS]$ sudo rpm --test -Uvh ../RPMS/foo-2.5.1-1.i386.rpm

I don't think this is a bug, as upgrade implies erase/install so the final
system has no conflicting packages and the transaction is satisfied.


Note You need to log in before you can comment on or make changes to this bug.