Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83735 - mozilla hangs after upgrading to Raw Hide
Summary: mozilla hangs after upgrading to Raw Hide
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben LaHaise
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-07 18:04 UTC by Jonathan Kamens
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:38 UTC


Attachments (Terms of Use)

Description Jonathan Kamens 2003-02-07 18:04:47 UTC
I am using mozilla-1.2.1-20, glibc-2.3.1-40, kernel-2.4.20-2.36.  I have 
renamed /lib/tls to /lib/notls to disable NPTL.  After upgrading to mozilla-
1.2.1-20 and kernel-2.4.20-2.36 (I didn't upgrade glibc), mozilla now hangs 
when I start it up.  This did not happen yesterday when I was using mozilla-
1.2.1-19 and kernel-2.4.20-2.34.

If I kill the hung mozilla process, it leaves five threads hanging around.  If 
I send kill -9 to those five threads, two of them die but the other three 
don't, and won't regardless of repeated kill -9s.  ps shows them in state "S".

Comment 1 Jonathan Kamens 2003-02-07 18:44:24 UTC
This is a kernel problem, not a mozilla problem.  Downgrading to
kernel-2.4.20-2.21 made it go away.  Note that renaming /lib/notls to /lib/tls
and rebooting with kernel-2.4.20-36 did NOT make it go away.

I also saw "host" and "nslookup" hang.


Comment 2 Christopher Blizzard 2003-02-07 20:42:44 UTC
I hear rumour that bcrl has a patch for this.

Comment 3 Bill Nottingham 2003-02-11 06:18:41 UTC

*** This bug has been marked as a duplicate of 83664 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:38 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.