Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83723 - Generic PS/2 mouse setting forgotten when out of X system
Summary: Generic PS/2 mouse setting forgotten when out of X system
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-mouse
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 16:45 UTC by Jani Alinikula
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-10 19:57:11 UTC


Attachments (Terms of Use)

Description Jani Alinikula 2003-02-07 16:45:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
I have to re-select mouse type from redhat-config-mouse every time I login,
otherwise my mouse moves slowly with no acceleration. Otherwise it works OK.

In this state, changing mouse acceleration parameters from the prefences menu
(gnome-mouse-properties) doesn't seem to produce as good feel to the mouse as
re-selecting mouse type from redhat-config-mouse.

This forgetting happens also when I go to the text terminal and back to X.

I have a Logitech optical Wheel mouse.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.(mouse ok)
2.Ctrl-Alt-F1
3.Ctrl-Alt-F1
4.(mouse bad)
    

Additional info:

Comment 1 Jani Alinikula 2003-02-07 17:04:23 UTC
Sorry, there was a bug in the last report...

Steps to Reproduce should of course have been:
1.(mouse ok)
2.Ctrl-Alt-F1
3.Ctrl-Alt-F7
4.(mouse bad)
    



Comment 2 Jani Alinikula 2003-02-10 19:40:38 UTC
When configuring the mouse, redhat-config-mouse restarts gpm. gpm seems to
change mouse resolution setting to make the mouse move faster. When returning to
X from text terminal, the resolution setting is forgotten. Adding: 'Option 
"Resolution" "200"' to /etc/X11/XF68Config-4 helps and the movement stays ok. 

So the bug isn't acually in redhat-config-mouse, but maybe it should add such a
line by default, because the default setting (at least for my mouse) really
isn't useful at all.


Comment 3 Brent Fox 2003-02-10 19:57:11 UTC
Strange.  I have a Logitech Optical Wheel mouse and I don't see this behavior at
all.  I usually have the acceleration and sensitivity set pretty high on my
mouse.  When I press Alt-F1, it takes me to console mode.  gpm is running and
the mouse works in console mode.  Pressing Alt-F7 takes me back to X and the
acceleration  and sensitivity settings are still in effect.  

Also, I think that switching between console mode and X is relatively uncommon
so I don't think that this is a major problem.  At any rate, it is not a problem
with redhat-config-mouse.  I can't say whether the actual problem is with gpm,
XFree86, Gnome or KDE.  

I think that adding the "Resolution" "200" to the XF86Config file is the wrong
approach since that setting may not be correct for everyone.  Closing as
'worksforme'.


Note You need to log in before you can comment on or make changes to this bug.